CVE-2022-24999 qs vulnerable to Prototype Pollution
An attacker can cause a Node.js process hang via a crafted query string in the qs library, leading to denial of service.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-24999?
CVE-2022-24999 is a high-severity denial of service vulnerability in Debian Debian Linux, published on 26 Nov 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
qs before 6.10.3, as used in Express before 4.17.3 and other products, allows attackers to cause a Node process hang for an Express application because an __ proto__ key can be used. In many typical Express use cases, an unauthenticated remote attacker can place the attack payload in the query string of the URL that is used to visit the application, such as a[__proto__]=b&a[__proto__]&a[length]=100000000. The fix was backported to qs 6.9.7, 6.8.3, 6.7.3, 6.6.1, 6.5.3, 6.4.1, 6.3.3, and 6.2.4 (and therefore Express 4.17.3, which has "deps: [email protected]" in its release description, is not vulnerable).
Weakness: CWE-1321
Which versions are affected by CVE-2022-24999?
18 open source packages ship an affected version, including qs. It affects 3 products.
| Package | Affected | Fixed in |
|---|---|---|
qs npm | All versions | 6.2.4 |
qs npm | All versions | 6.2.4 |
qs npm | From 6.10.0 | 6.10.3 |
qs npm | From 6.10.0 | 6.10.3 |
qs npm | From 6.3.0 | 6.3.3 |
qs npm | From 6.3.0 | 6.3.3 |
12 more packages
qs npm | From 6.4.0 | 6.4.1 |
qs npm | From 6.4.0 | 6.4.1 |
qs npm | From 6.5.0 | 6.5.3 |
qs npm | From 6.5.0 | 6.5.3 |
qs npm | From 6.6.0 | 6.6.1 |
qs npm | From 6.6.0 | 6.6.1 |
qs npm | From 6.7.0 | 6.7.3 |
qs npm | From 6.7.0 | 6.7.3 |
qs npm | From 6.8.0 | 6.8.3 |
qs npm | From 6.8.0 | 6.8.3 |
qs npm | From 6.9.0 | 6.9.7 |
qs npm | From 6.9.0 | 6.9.7 |
Products include Debian Debian Linux, Openjsf Express, Qs Project Qs.
How do I fix CVE-2022-24999?
Upgrade qs to a fixed version for your release line: 6.2.4, 6.10.3, 6.3.3 or 6.4.1.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2022-24999 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-24999 exists.
Public exploit code: 1 proofs of concept on GitHub.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as AZL-44307, AZL-45051, CLSA-2026-1773274551, CLSA-2026-1784596269, CLSA-2026-1784596314, CLSA-2026-1784596344 and 14 more.