# CVE-2022-24999: qs vulnerable to Prototype Pollution

> An attacker can cause a Node.js process hang via a crafted query string in the qs library, leading to denial of service.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Nov 2022
- **Updated:** 29 Apr 2025
- **Also known as:** AZL-44307, AZL-45051, CLSA-2026-1773274551, CLSA-2026-1784596269, CLSA-2026-1784596314, CLSA-2026-1784596344, DEBIAN-CVE-2022-24999, DLA-3299-1, GHSA-hrpp-h998-j3pp, MGASA-2023-0053, MINI-3p6w-rx5f-2hc7, OESA-2024-1338, OESA-2024-1400, OESA-2024-1401, OESA-2024-1402, OESA-2024-1403, OESA-2024-1404, ROOT-APP-NPM-CVE-2022-24999, UBUNTU-CVE-2022-24999, USN-7693-1

## What is CVE-2022-24999?

CVE-2022-24999 is a high-severity denial of service vulnerability in Debian Debian Linux, published on 26 Nov 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

qs before 6.10.3, as used in Express before 4.17.3 and other products, allows attackers to cause a Node process hang for an Express application because an __ proto__ key can be used. In many typical Express use cases, an unauthenticated remote attacker can place the attack payload in the query string of the URL that is used to visit the application, such as a[__proto__]=b&a[__proto__]&a[length]=100000000. The fix was backported to qs 6.9.7, 6.8.3, 6.7.3, 6.6.1, 6.5.3, 6.4.1, 6.3.3, and 6.2.4 (and therefore Express 4.17.3, which has "deps: qs@6.9.7" in its release description, is not vulnerable).

Weakness: CWE-1321 (Improperly Controlled Modification of Object Prototype Attributes)

## Which versions are affected by CVE-2022-24999?

18 open source packages ship an affected version, including qs. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `qs` | npm | All versions | 6.2.4 |
| `qs` | npm | All versions | 6.2.4 |
| `qs` | npm | From 6.10.0 | 6.10.3 |
| `qs` | npm | From 6.10.0 | 6.10.3 |
| `qs` | npm | From 6.3.0 | 6.3.3 |
| `qs` | npm | From 6.3.0 | 6.3.3 |
| `qs` | npm | From 6.4.0 | 6.4.1 |
| `qs` | npm | From 6.4.0 | 6.4.1 |
| `qs` | npm | From 6.5.0 | 6.5.3 |
| `qs` | npm | From 6.5.0 | 6.5.3 |
| `qs` | npm | From 6.6.0 | 6.6.1 |
| `qs` | npm | From 6.6.0 | 6.6.1 |
| `qs` | npm | From 6.7.0 | 6.7.3 |
| `qs` | npm | From 6.7.0 | 6.7.3 |
| `qs` | npm | From 6.8.0 | 6.8.3 |
| `qs` | npm | From 6.8.0 | 6.8.3 |
| `qs` | npm | From 6.9.0 | 6.9.7 |
| `qs` | npm | From 6.9.0 | 6.9.7 |

Products: Debian Debian Linux, Openjsf Express, Qs Project Qs.

## How do I fix CVE-2022-24999?

Upgrade qs to a fixed version for your release line: 6.2.4, 6.10.3, 6.3.3 or 6.4.1.

## Is CVE-2022-24999 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-24999 exists.

Public exploit code:

- "qs" prototype poisoning vulnerability ( CVE-2022-24999 ) (github_poc): https://github.com/9pings/CVE-2022-24999

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-24999 and fix it if it is affected.

What it is: CVE-2022-24999 is a high-severity denial of service vulnerability in Debian Debian Linux, published on 26 Nov 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-24999 exists.

Affected packages and fixed versions:
- qs (npm): affected all versions; fixed in 6.2.4
- qs (npm): affected all versions; fixed in 6.2.4
- qs (npm): affected from 6.10.0; fixed in 6.10.3
- qs (npm): affected from 6.10.0; fixed in 6.10.3
- qs (npm): affected from 6.3.0; fixed in 6.3.3
- qs (npm): affected from 6.3.0; fixed in 6.3.3
- qs (npm): affected from 6.4.0; fixed in 6.4.1
- qs (npm): affected from 6.4.0; fixed in 6.4.1
- qs (npm): affected from 6.5.0; fixed in 6.5.3
- qs (npm): affected from 6.5.0; fixed in 6.5.3
- qs (npm): affected from 6.6.0; fixed in 6.6.1
- qs (npm): affected from 6.6.0; fixed in 6.6.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-24999/ (Markdown: https://insights.sbomify.com/CVE-2022-24999/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-24999
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-24999
- OSV: https://osv.dev/vulnerability/CVE-2022-24999

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-24999/
Summaries are generated and may contain mistakes; the official description above is the record.
