CVE-2022-2500 Cross-site scripting in GitLab

Medium 4.4 Published Updated

Stored XSS in GitLab job error messages allows attackers to perform arbitrary actions on behalf of victims.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2022-2500?

CVE-2022-2500 is a medium-severity cross-site scripting vulnerability in Gitlab Gitlab, published on 5 Aug 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

A cross-site scripting issue has been discovered in GitLab CE/EE affecting all versions before 15.0.5, 15.1 prior to 15.1.4, and 15.2 prior to 15.2.1. A stored XSS flaw in job error messages allows attackers to perform arbitrary actions on behalf of victims at client side.

Weakness: CWE-79

Which versions are affected by CVE-2022-2500?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiAll versions15.0.5, 15.1.4, 15.2.1

Products include Gitlab Gitlab.

How do I fix CVE-2022-2500?

Upgrade gitlab to a fixed version for your release line: 15.0.5, 15.1.4 or 15.2.1.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2022-2500 being exploited?

There is no known exploitation of CVE-2022-2500 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2022-2500, GHSA-4jhx-xj9w-gw72, UBUNTU-CVE-2022-2500.

Is CVE-2022-2500 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free