CVE-2022-2501 Security feature bypass in GitLab
Attackers can bypass IP allow-listing restrictions to download artifacts if they possess valid permissions, requiring an upgrade to GitLab EE.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-2501?
CVE-2022-2501 is a medium-severity vulnerability in Gitlab Gitlab, published on 5 Aug 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
An improper access control issue in GitLab EE affecting all versions from 12.0 prior to 15.0.5, 15.1 prior to 15.1.4, and 15.2 prior to 15.2.1 allows an attacker to bypass IP allow-listing and download artifacts. This attack only bypasses IP allow-listing, proper permissions are still required.
Weakness: CWE-863
Which versions are affected by CVE-2022-2501?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | From 12.0.0 | 15.0.5, 15.1.4, 15.2.1 |
Products include Gitlab Gitlab.
How do I fix CVE-2022-2501?
Upgrade gitlab to a fixed version for your release line: 15.0.5, 15.1.4 or 15.2.1.
Is CVE-2022-2501 being exploited?
There is no known exploitation of CVE-2022-2501 in the wild and no public exploit code.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2022-2501, GHSA-5c73-fgcq-grvm, UBUNTU-CVE-2022-2501.