{"answers":{"affected":"1 open source package ship an affected version, including gitlab. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-2501 in the wild and no public exploit code.","fix":"Upgrade gitlab to a fixed version for your release line: 15.0.5, 15.1.4 or 15.2.1.","what":"CVE-2022-2501 is a medium-severity vulnerability in Gitlab Gitlab, published on 5 Aug 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-2501 and fix it if it is affected.\n\nWhat it is: CVE-2022-2501 is a medium-severity vulnerability in Gitlab Gitlab, published on 5 Aug 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-2501 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- gitlab (Bitnami): affected from 12.0.0; fixed in 15.0.5, 15.1.4, 15.2.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-2501/ (Markdown: https://insights.sbomify.com/CVE-2022-2501/index.md)","id":"CVE-2022-2501","markdown":"https://insights.sbomify.com/CVE-2022-2501/index.md","name":"CVE-2022-2501","record":{"aliases":["BIT-gitlab-2022-2501","GHSA-5c73-fgcq-grvm","UBUNTU-CVE-2022-2501"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"GitLab Enterprise Edition","requires_auth":"none","summary":"Attackers can bypass IP allow-listing restrictions to download artifacts if they possess valid permissions, requiring an upgrade to GitLab EE.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitLab","cpe":[{"product":"gitlab","vendor":"gitlab"}],"cvss":{"score":5.9,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-863","name":"Incorrect Authorization"}],"description":"An improper access control issue in GitLab EE affecting all versions from 12.0 prior to 15.0.5, 15.1 prior to 15.1.4, and 15.2 prior to 15.2.1 allows an attacker to bypass IP allow-listing and download artifacts. This attack only bypasses IP allow-listing, proper permissions are still required.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Security feature bypass in GitLab","id":"CVE-2022-2501","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"gitlab:gitlab","products":["gitlab:gitlab"],"type":"security_feature_bypass","year":"2022"},"n_packages":1,"n_references":3,"next":{"headline":"Denial of service in RTU500 series","id":"CVE-2022-2502"},"packages":[{"ecosystem":"Bitnami","fixed":["15.0.5","15.1.4","15.2.1"],"introduced":["12.0.0","15.1.0","15.2.0"],"last_affected":[],"package":"gitlab","purl":"pkg:bitnami/gitlab","source":"BIT-gitlab-2022-2501"}],"prev":{"headline":"Cross-site scripting in GitLab","id":"CVE-2022-2500"},"products":["GitLab"],"published":"2022-08-05","related":[{"cvss_score":10,"headline":"GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound","id":"CVE-2026-97229","kev_date_added":"2026-10-29","published":"2026-10-13"},{"cvss_score":10,"headline":"GitLab Community Edition and Enterprise Edition Path Traversal","id":"CVE-2026-85706","kev_date_added":"2026-09-11","published":"2026-09-12"},{"cvss_score":10,"headline":"GitLab Community and Enterprise Editions Improper Access Control","id":"CVE-2023-7028","kev_date_added":"2024-05-01","published":"2024-01-12"},{"cvss_score":10,"headline":"GitLab Community and Enterprise Editions Remote Code Execution","id":"CVE-2021-22205","kev_date_added":"2021-11-03","published":"2021-04-23"},{"cvss_score":6.8,"headline":"GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)","id":"CVE-2021-39935","kev_date_added":"2026-02-03","published":"2021-12-13"},{"cvss_score":6.8,"headline":"GitLab Server-Side Request Forgery (SSRF)","id":"CVE-2021-22175","kev_date_added":"2026-02-18","published":"2021-06-11"},{"cvss_score":10,"headline":"Integer Overflow or Wraparound in GitLab","id":"CVE-2026-110264","kev_date_added":null,"published":"2026-10-22"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["GitLab"]},"summary":"Attackers can bypass IP allow-listing restrictions to download artifacts if they possess valid permissions, requiring an upgrade to GitLab EE.","url":"https://insights.sbomify.com/CVE-2022-2501/"}