# CVE-2022-2501: Security feature bypass in GitLab

> Attackers can bypass IP allow-listing restrictions to download artifacts if they possess valid permissions, requiring an upgrade to GitLab EE.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Aug 2022
- **Updated:** 3 Aug 2024
- **Also known as:** BIT-gitlab-2022-2501, GHSA-5c73-fgcq-grvm, UBUNTU-CVE-2022-2501

## What is CVE-2022-2501?

CVE-2022-2501 is a medium-severity vulnerability in Gitlab Gitlab, published on 5 Aug 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An improper access control issue in GitLab EE affecting all versions from 12.0 prior to 15.0.5, 15.1 prior to 15.1.4, and 15.2 prior to 15.2.1 allows an attacker to bypass IP allow-listing and download artifacts. This attack only bypasses IP allow-listing, proper permissions are still required.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2022-2501?

1 open source package ship an affected version, including gitlab. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gitlab` | Bitnami | From 12.0.0 | 15.0.5, 15.1.4, 15.2.1 |

Products: Gitlab Gitlab.

## How do I fix CVE-2022-2501?

Upgrade gitlab to a fixed version for your release line: 15.0.5, 15.1.4 or 15.2.1.

## Is CVE-2022-2501 being exploited?

There is no known exploitation of CVE-2022-2501 in the wild and no public exploit code.

## Other vulnerabilities in Gitlab Gitlab

- [CVE-2026-97229](https://insights.sbomify.com/CVE-2026-97229/): GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound (critical 10.0, exploited in the wild)
- [CVE-2026-85706](https://insights.sbomify.com/CVE-2026-85706/): GitLab Community Edition and Enterprise Edition Path Traversal (critical 10.0, exploited in the wild)
- [CVE-2023-7028](https://insights.sbomify.com/CVE-2023-7028/): GitLab Community and Enterprise Editions Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2021-22205](https://insights.sbomify.com/CVE-2021-22205/): GitLab Community and Enterprise Editions Remote Code Execution (critical 10.0, exploited in the wild)
- [CVE-2021-39935](https://insights.sbomify.com/CVE-2021-39935/): GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF) (medium 6.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-2501 and fix it if it is affected.

What it is: CVE-2022-2501 is a medium-severity vulnerability in Gitlab Gitlab, published on 5 Aug 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-2501 in the wild and no public exploit code.

Affected packages and fixed versions:
- gitlab (Bitnami): affected from 12.0.0; fixed in 15.0.5, 15.1.4, 15.2.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-2501/ (Markdown: https://insights.sbomify.com/CVE-2022-2501/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-2501
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-2501
- OSV: https://osv.dev/vulnerability/CVE-2022-2501

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-2501/
Summaries are generated and may contain mistakes; the official description above is the record.
