CVE-2022-25037 wangEditor was discovered to contain a cross-site scripting (XSS) vulnerability via the image upload function

Medium 5.4 Published Updated

An attacker can execute arbitrary scripts via the image upload function in wanEditor, potentially compromising user sessions.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2022-25037?

CVE-2022-25037 is a medium-severity cross-site scripting vulnerability in n/a, published on 31 May 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

An issue in wanEditor v4.7.11 and fixed in v.4.7.12 and v.5 was discovered to contain a cross-site scripting (XSS) vulnerability via the image upload function.

Weakness: CWE-79

Which versions are affected by CVE-2022-25037?

2 open source packages ship an affected version, including @wangeditor/editor.

PackageAffectedFixed in
@wangeditor/editor npmAll versions4.7.12
@wangeditor/editor npmAll versions4.7.12

How do I fix CVE-2022-25037?

Upgrade @wangeditor/editor to 4.7.12 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2022-25037 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-25037 exists.

Sources

Also known as GHSA-9hfw-cvf4-5x25.

Is CVE-2022-25037 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free