{"answers":{"affected":"2 open source packages ship an affected version, including @wangeditor/editor.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-25037 exists.","fix":"Upgrade @wangeditor/editor to 4.7.12 or later.","what":"CVE-2022-25037 is a medium-severity cross-site scripting vulnerability in n/a, published on 31 May 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-25037 and fix it if it is affected.\n\nWhat it is: CVE-2022-25037 is a medium-severity cross-site scripting vulnerability in n/a, published on 31 May 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-25037 exists.\n\nAffected packages and fixed versions:\n- @wangeditor/editor (npm): affected all versions; fixed in 4.7.12\n- @wangeditor/editor (npm): affected all versions; fixed in 4.7.12\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-25037/ (Markdown: https://insights.sbomify.com/CVE-2022-25037/index.md)","id":"CVE-2022-25037","markdown":"https://insights.sbomify.com/CVE-2022-25037/index.md","name":"CVE-2022-25037","record":{"aliases":["GHSA-9hfw-cvf4-5x25"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"JavaScript rich text editor","requires_auth":"low_privilege","summary":"An attacker can execute arbitrary scripts via the image upload function in wanEditor, potentially compromising user sessions.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[],"cvss":{"score":5.4,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"An issue in wanEditor v4.7.11 and fixed in v.4.7.12 and v.5 was discovered to contain a cross-site scripting (XSS) vulnerability via the image upload function.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"wangEditor was discovered to contain a cross-site scripting (XSS) vulnerability via the image upload function","id":"CVE-2022-25037","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2022"},"n_packages":2,"n_references":2,"next":{"headline":"Cross-site scripting in n/a","id":"CVE-2022-25038"},"packages":[{"ecosystem":"npm","fixed":["4.7.12"],"introduced":["0"],"last_affected":[],"package":"@wangeditor/editor","purl":null,"source":"GHSA-9hfw-cvf4-5x25"},{"ecosystem":"npm","fixed":["4.7.12"],"introduced":["0"],"last_affected":[],"package":"@wangeditor/editor","purl":"pkg:npm/%40wangeditor/editor","source":"GHSA-9hfw-cvf4-5x25"}],"prev":{"headline":"Privilege escalation in n/a","id":"CVE-2022-25031"},"products":["n/a"],"published":"2024-05-31","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-02-13","vendors":["n/a"]},"summary":"An attacker can execute arbitrary scripts via the image upload function in wanEditor, potentially compromising user sessions.","url":"https://insights.sbomify.com/CVE-2022-25037/"}