# CVE-2022-25037: wangEditor was discovered to contain a cross-site scripting (XSS) vulnerability via the image upload function

> An attacker can execute arbitrary scripts via the image upload function in wanEditor, potentially compromising user sessions.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 31 May 2024
- **Updated:** 13 Feb 2025
- **Also known as:** GHSA-9hfw-cvf4-5x25

## What is CVE-2022-25037?

CVE-2022-25037 is a medium-severity cross-site scripting vulnerability in n/a, published on 31 May 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

An issue in wanEditor v4.7.11 and fixed in v.4.7.12 and v.5 was discovered to contain a cross-site scripting (XSS) vulnerability via the image upload function.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2022-25037?

2 open source packages ship an affected version, including @wangeditor/editor.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@wangeditor/editor` | npm | All versions | 4.7.12 |
| `@wangeditor/editor` | npm | All versions | 4.7.12 |

## How do I fix CVE-2022-25037?

Upgrade @wangeditor/editor to 4.7.12 or later.

## Is CVE-2022-25037 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-25037 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-25037 and fix it if it is affected.

What it is: CVE-2022-25037 is a medium-severity cross-site scripting vulnerability in n/a, published on 31 May 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-25037 exists.

Affected packages and fixed versions:
- @wangeditor/editor (npm): affected all versions; fixed in 4.7.12
- @wangeditor/editor (npm): affected all versions; fixed in 4.7.12

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-25037/ (Markdown: https://insights.sbomify.com/CVE-2022-25037/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-25037
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-25037
- OSV: https://osv.dev/vulnerability/CVE-2022-25037

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-25037/
Summaries are generated and may contain mistakes; the official description above is the record.
