# CVE-2022-25146: Liferay Portal and Liferay DXP fails to check origin of event messages

> Attackers can exfiltrate CSRF tokens from Liferay Portal Remote App modules via crafted event messages due to missing origin checks.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Mar 2022
- **Updated:** 9 Jul 2026
- **Also known as:** BIT-liferay-2022-25146, GHSA-ghw5-998m-vw4w

## What is CVE-2022-25146?

CVE-2022-25146 is a medium-severity vulnerability in Liferay Digital Experience Platform, published on 2 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The Remote App module in Liferay Portal Liferay Portal v7.4.3.4 through v7.4.3.8 and Liferay DXP 7.4 before update 5 does not check if the origin of event messages it receives matches the origin of the Remote App, allowing attackers to exfiltrate the CSRF token via a crafted event message.

Weakness: CWE-346 (Origin Validation Error)

## Which versions are affected by CVE-2022-25146?

5 open source packages ship an affected version, including com.liferay.portal:release.dxp.bom, liferay and com.liferay:com.liferay.remote.app.web. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.liferay.portal:release.dxp.bom` | Maven | All versions | 7.4.13.u5 |
| `com.liferay.portal:release.dxp.bom` | Maven | All versions | 7.4.13.u5 |
| `liferay` | Bitnami | All versions | 7.4.0 |
| `com.liferay:com.liferay.remote.app.web` | Maven | All versions | 2.0.21 |
| `com.liferay:com.liferay.remote.app.web` | Maven | All versions | 2.0.21 |

Products: Liferay Digital Experience Platform, Liferay Liferay Portal.

## How do I fix CVE-2022-25146?

Upgrade com.liferay.portal:release.dxp.bom to 7.4.13.u5 or later.

## Is CVE-2022-25146 being exploited?

There is no known exploitation of CVE-2022-25146 in the wild and no public exploit code.

## Other vulnerabilities in Liferay Digital Experience Platform

- [CVE-2024-8980](https://insights.sbomify.com/CVE-2024-8980/): Liferay Portal and Liferay DXP Vulnerable to CSRF in the Script Console (critical 9.6)
- [CVE-2023-42496](https://insights.sbomify.com/CVE-2023-42496/): Liferay Portal and Liferay DXP vulnerable to reflected Cross-site Scripting (critical 9.6)
- [CVE-2023-42498](https://insights.sbomify.com/CVE-2023-42498/): Liferay Portal Language Override edit screen and Liferay DXP vulnerable to reflected Cross-site Scripting (critical 9.6)
- [CVE-2024-25147](https://insights.sbomify.com/CVE-2024-25147/): Liferay Portal and Liferay DXP vulnerable to Cross-site Scripting (critical 9.6)
- [CVE-2024-26269](https://insights.sbomify.com/CVE-2024-26269/): Liferay Portal Frontend JS module's portlet.js and Liferay DXP vulnerable to Cross-site Scripting (critical 9.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-25146 and fix it if it is affected.

What it is: CVE-2022-25146 is a medium-severity vulnerability in Liferay Digital Experience Platform, published on 2 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-25146 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.liferay.portal:release.dxp.bom (Maven): affected all versions; fixed in 7.4.13.u5
- com.liferay.portal:release.dxp.bom (Maven): affected all versions; fixed in 7.4.13.u5
- liferay (Bitnami): affected all versions; fixed in 7.4.0
- com.liferay:com.liferay.remote.app.web (Maven): affected all versions; fixed in 2.0.21
- com.liferay:com.liferay.remote.app.web (Maven): affected all versions; fixed in 2.0.21

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-25146/ (Markdown: https://insights.sbomify.com/CVE-2022-25146/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-25146
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-25146
- OSV: https://osv.dev/vulnerability/CVE-2022-25146

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-25146/
Summaries are generated and may contain mistakes; the official description above is the record.
