{"answers":{"affected":"2 open source packages ship an affected version, including org.apache.flume.flume-ng-sources:flume-jms-source. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-25167 in the wild and no public exploit code.","fix":"Upgrade org.apache.flume.flume-ng-sources:flume-jms-source to 1.10.0 or later.","what":"CVE-2022-25167 is a critical code injection vulnerability in Apache Flume, published on 14 Jun 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-25167 and fix it if it is affected.\n\nWhat it is: CVE-2022-25167 is a critical code injection vulnerability in Apache Flume, published on 14 Jun 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-25167 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.flume.flume-ng-sources:flume-jms-source (Maven): affected from 1.4.0; fixed in 1.10.0\n- org.apache.flume.flume-ng-sources:flume-jms-source (Maven): affected from 1.4.0; fixed in 1.10.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-25167/ (Markdown: https://insights.sbomify.com/CVE-2022-25167/index.md)","id":"CVE-2022-25167","markdown":"https://insights.sbomify.com/CVE-2022-25167/index.md","name":"CVE-2022-25167","record":{"aliases":["GHSA-x5m7-rwfx-w7qm"],"analysis":{"component_type":"server_software","fix_type":"patch","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"Apache Flume","requires_auth":"none","summary":"Attackers can execute arbitrary code in Apache Flume if JMS Source uses a malicious LDAP JNDI URI, requiring specific configuration.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"flume","vendor":"apache"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-74","name":"Improper Neutralization of Special Elements in Output Used by a Downstream Component"},{"id":"CWE-20","name":"Improper Input Validation"}],"description":"Apache Flume versions 1.4.0 through 1.9.0 are vulnerable to a remote code execution (RCE) attack when a configuration uses a JMS Source with a JNDI LDAP data source URI when an attacker has control of the target LDAP server. This issue is fixed by limiting JNDI to allow only the use of the java protocol or no protocol.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache Flume vulnerable to a JNDI RCE in JMSSource","id":"CVE-2022-25167","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"code_injection","year":"2022"},"n_packages":2,"n_references":3,"next":{"headline":"Command injection in org.apache.hadoop.fs.FileUtil.unTarUsingTar","id":"CVE-2022-25168"},"packages":[{"ecosystem":"Maven","fixed":["1.10.0"],"introduced":["1.4.0"],"last_affected":[],"package":"org.apache.flume.flume-ng-sources:flume-jms-source","purl":null,"source":"GHSA-x5m7-rwfx-w7qm"},{"ecosystem":"Maven","fixed":["1.10.0"],"introduced":["1.4.0"],"last_affected":[],"package":"org.apache.flume.flume-ng-sources:flume-jms-source","purl":"pkg:maven/org.apache.flume.flume-ng-sources/flume-jms-source","source":"GHSA-x5m7-rwfx-w7qm"}],"prev":{"headline":"Information disclosure in n/a","id":"CVE-2022-25166"},"products":["Apache Flume"],"published":"2022-06-14","related":[{"cvss_score":9.8,"headline":"Apache Flume prior to 1.11.0 has an Improper Input Validation (JNDI Injection) in JMSSource","id":"CVE-2022-42468","kev_date_added":null,"published":"2022-10-26"},{"cvss_score":9.8,"headline":"Improper Input Validation (JNDI Injection) in JMSMessageConsumer","id":"CVE-2022-34916","kev_date_added":null,"published":"2022-08-21"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["Apache Software Foundation"]},"summary":"Attackers can execute arbitrary code in Apache Flume if JMS Source uses a malicious LDAP JNDI URI, requiring specific configuration.","url":"https://insights.sbomify.com/CVE-2022-25167/"}