{"answers":{"affected":"2 open source packages ship an affected version, including org.jenkins-ci.plugins:fortify. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-25188 in the wild and no public exploit code.","fix":"Upgrade org.jenkins-ci.plugins:fortify to 20.2.35 or later.","what":"CVE-2022-25188 is a medium-severity path traversal vulnerability in Jenkins Fortify Plugin, published on 15 Feb 2022. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-25188 and fix it if it is affected.\n\nWhat it is: CVE-2022-25188 is a medium-severity path traversal vulnerability in Jenkins Fortify Plugin, published on 15 Feb 2022. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-25188 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jenkins-ci.plugins:fortify (Maven): affected all versions; fixed in 20.2.35\n- org.jenkins-ci.plugins:fortify (Maven): affected all versions; fixed in 20.2.35\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-25188/ (Markdown: https://insights.sbomify.com/CVE-2022-25188/index.md)","id":"CVE-2022-25188","markdown":"https://insights.sbomify.com/CVE-2022-25188/index.md","name":"CVE-2022-25188","record":{"aliases":["GHSA-23h5-8ph6-7rfc"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins Fortify Plugin","requires_auth":"low_privilege","summary":"Attackers with Item/Configure permission can write or overwrite XML files on the Jenkins controller via unsanitized Pipeline step parameters.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jenkins","cpe":[{"product":"fortify","vendor":"jenkins"}],"cvss":{"score":4.3,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"Jenkins Fortify Plugin 20.2.34 and earlier does not sanitize the appName and appVersion parameters of its Pipeline steps, allowing attackers with Item/Configure permission to write or overwrite .xml files on the Jenkins controller file system with content not controllable by the attacker.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Path traversal vulnerability in Jenkins Fortify Plugin","id":"CVE-2022-25188","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"path_traversal","year":"2022"},"n_packages":2,"n_references":2,"next":{"headline":"Stored Cross-site Scripting vulnerability in Jenkins Custom Checkbox Parameter Plugin","id":"CVE-2022-25189"},"packages":[{"ecosystem":"Maven","fixed":["20.2.35"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:fortify","purl":null,"source":"GHSA-23h5-8ph6-7rfc"},{"ecosystem":"Maven","fixed":["20.2.35"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:fortify","purl":"pkg:maven/org.jenkins-ci.plugins/fortify","source":"GHSA-23h5-8ph6-7rfc"}],"prev":{"headline":"Jenkins Support Core Plugin stores sensitive data in plain text","id":"CVE-2022-25187"},"products":["Jenkins Fortify Plugin"],"published":"2022-02-15","related":[{"cvss_score":4.3,"headline":"HTML injection vulnerability in Fortify Plugin","id":"CVE-2023-4303","kev_date_added":null,"published":"2023-08-21"},{"cvss_score":4.3,"headline":"Fortify Plugin stored credentials in plain text","id":"CVE-2020-2107","kev_date_added":null,"published":"2020-01-29"},{"cvss_score":4.2,"headline":"CSRF vulnerability in Fortify Plugin allow capturing credentials","id":"CVE-2023-4301","kev_date_added":null,"published":"2023-08-21"},{"cvss_score":4.2,"headline":"Missing permission checks in Fortify Plugin allow capturing credentials","id":"CVE-2023-4302","kev_date_added":null,"published":"2023-08-21"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["Jenkins project"]},"summary":"Attackers with Item/Configure permission can write or overwrite XML files on the Jenkins controller via unsanitized Pipeline step parameters.","url":"https://insights.sbomify.com/CVE-2022-25188/"}