{"answers":{"affected":"2 open source packages ship an affected version, including io.jenkins.plugins:embotics-vcommander. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-25193 in the wild and no public exploit code.","fix":"Upgrade io.jenkins.plugins:embotics-vcommander to 2.0 or later.","what":"CVE-2022-25193 is a medium-severity missing authorization vulnerability in Jenkins Snow Commander Plugin, published on 15 Feb 2022. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-25193 and fix it if it is affected.\n\nWhat it is: CVE-2022-25193 is a medium-severity missing authorization vulnerability in Jenkins Snow Commander Plugin, published on 15 Feb 2022. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-25193 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- io.jenkins.plugins:embotics-vcommander (Maven): affected all versions; fixed in 2.0\n- io.jenkins.plugins:embotics-vcommander (Maven): affected all versions; fixed in 2.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-25193/ (Markdown: https://insights.sbomify.com/CVE-2022-25193/index.md)","id":"CVE-2022-25193","markdown":"https://insights.sbomify.com/CVE-2022-25193/index.md","name":"CVE-2022-25193","record":{"aliases":["GHSA-2phq-ghf8-6586"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins Snow Commander Plugin","requires_auth":"low_privilege","summary":"Attackers with read access can capture Jenkins credentials by connecting to an attacker-controlled server due to missing permission checks.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jenkins","cpe":[{"product":"snow_commander","vendor":"jenkins"}],"cvss":{"score":6.5,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-862","name":"Missing Authorization"}],"description":"Missing permission checks in Jenkins Snow Commander Plugin 1.10 and earlier allow attackers with Overall/Read permission to connect to an attacker-specified webserver using attacker-specified credentials IDs obtained through another method, capturing credentials stored in Jenkins.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Jenkins Snow Commander Plugin prior to 2.0 vulnerable to Missing Authorization","id":"CVE-2022-25193","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"missing_authorization","year":"2022"},"n_packages":2,"n_references":1,"next":{"headline":"CSRF vulnerability in Jenkins autonomiq plugin","id":"CVE-2022-25194"},"packages":[{"ecosystem":"Maven","fixed":["2.0"],"introduced":["0"],"last_affected":[],"package":"io.jenkins.plugins:embotics-vcommander","purl":null,"source":"GHSA-2phq-ghf8-6586"},{"ecosystem":"Maven","fixed":["2.0"],"introduced":["0"],"last_affected":[],"package":"io.jenkins.plugins:embotics-vcommander","purl":"pkg:maven/io.jenkins.plugins/embotics-vcommander","source":"GHSA-2phq-ghf8-6586"}],"prev":{"headline":"Jenkins Snow Commander Plugin 2.0 vulnerable to Cross-Site Request Forgery","id":"CVE-2022-25192"},"products":["Jenkins Snow Commander Plugin"],"published":"2022-02-15","related":[{"cvss_score":8.8,"headline":"Jenkins Snow Commander Plugin 2.0 vulnerable to Cross-Site Request Forgery","id":"CVE-2022-25192","kev_date_added":null,"published":"2022-02-15"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["Jenkins project"]},"summary":"Attackers with read access can capture Jenkins credentials by connecting to an attacker-controlled server due to missing permission checks.","url":"https://insights.sbomify.com/CVE-2022-25193/"}