{"answers":{"affected":"2 open source packages ship an affected version, including io.jenkins.plugins:autonomiq. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-25194 in the wild and no public exploit code.","fix":"Upgrade io.jenkins.plugins:autonomiq to 1.16 or later.","what":"CVE-2022-25194 is a high-severity vulnerability in Jenkins autonomiq Plugin, published on 15 Feb 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-25194 and fix it if it is affected.\n\nWhat it is: CVE-2022-25194 is a high-severity vulnerability in Jenkins autonomiq Plugin, published on 15 Feb 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2022-25194 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- io.jenkins.plugins:autonomiq (Maven): affected all versions; fixed in 1.16\n- io.jenkins.plugins:autonomiq (Maven): affected all versions; fixed in 1.16\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-25194/ (Markdown: https://insights.sbomify.com/CVE-2022-25194/index.md)","id":"CVE-2022-25194","markdown":"https://insights.sbomify.com/CVE-2022-25194/index.md","name":"CVE-2022-25194","record":{"aliases":["GHSA-g5wh-fw4m-2v28"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["security_bypass","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins autonomiq Plugin","requires_auth":"none","summary":"Attackers can force users to connect to malicious servers with attacker-controlled credentials via CSRF in the Jenkins autonomiq plugin.","user_interaction":"required","vuln_class":"csrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jenkins","cpe":[{"product":"autonomiq","vendor":"jenkins"}],"cvss":{"score":8.8,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-352","name":"Cross-Site Request Forgery"}],"description":"A cross-site request forgery (CSRF) vulnerability in Jenkins autonomiq Plugin 1.15 and earlier allows attackers to connect to an attacker-specified URL server using attacker-specified credentials.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"CSRF vulnerability in Jenkins autonomiq plugin","id":"CVE-2022-25194","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"csrf","year":"2022"},"n_packages":2,"n_references":1,"next":{"headline":"Missing permission check in Jenkins autonomiq Plugin","id":"CVE-2022-25195"},"packages":[{"ecosystem":"Maven","fixed":["1.16"],"introduced":["0"],"last_affected":[],"package":"io.jenkins.plugins:autonomiq","purl":null,"source":"GHSA-g5wh-fw4m-2v28"},{"ecosystem":"Maven","fixed":["1.16"],"introduced":["0"],"last_affected":[],"package":"io.jenkins.plugins:autonomiq","purl":"pkg:maven/io.jenkins.plugins/autonomiq","source":"GHSA-g5wh-fw4m-2v28"}],"prev":{"headline":"Jenkins Snow Commander Plugin prior to 2.0 vulnerable to Missing Authorization","id":"CVE-2022-25193"},"products":["Jenkins autonomiq Plugin"],"published":"2022-02-15","related":[{"cvss_score":4.3,"headline":"Missing permission check in Jenkins autonomiq Plugin","id":"CVE-2022-25195","kev_date_added":null,"published":"2022-02-15"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["Jenkins project"]},"summary":"Attackers can force users to connect to malicious servers with attacker-controlled credentials via CSRF in the Jenkins autonomiq plugin.","url":"https://insights.sbomify.com/CVE-2022-25194/"}