# CVE-2022-25194: CSRF vulnerability in Jenkins autonomiq plugin

> Attackers can force users to connect to malicious servers with attacker-controlled credentials via CSRF in the Jenkins autonomiq plugin.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 15 Feb 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-g5wh-fw4m-2v28

## What is CVE-2022-25194?

CVE-2022-25194 is a high-severity vulnerability in Jenkins autonomiq Plugin, published on 15 Feb 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

A cross-site request forgery (CSRF) vulnerability in Jenkins autonomiq Plugin 1.15 and earlier allows attackers to connect to an attacker-specified URL server using attacker-specified credentials.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2022-25194?

2 open source packages ship an affected version, including io.jenkins.plugins:autonomiq. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.jenkins.plugins:autonomiq` | Maven | All versions | 1.16 |
| `io.jenkins.plugins:autonomiq` | Maven | All versions | 1.16 |

Products: Jenkins Autonomiq.

## How do I fix CVE-2022-25194?

Upgrade io.jenkins.plugins:autonomiq to 1.16 or later.

## Is CVE-2022-25194 being exploited?

There is no known exploitation of CVE-2022-25194 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins autonomiq Plugin

- [CVE-2022-25195](https://insights.sbomify.com/CVE-2022-25195/): Missing permission check in Jenkins autonomiq Plugin (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-25194 and fix it if it is affected.

What it is: CVE-2022-25194 is a high-severity vulnerability in Jenkins autonomiq Plugin, published on 15 Feb 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-25194 in the wild and no public exploit code.

Affected packages and fixed versions:
- io.jenkins.plugins:autonomiq (Maven): affected all versions; fixed in 1.16
- io.jenkins.plugins:autonomiq (Maven): affected all versions; fixed in 1.16

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-25194/ (Markdown: https://insights.sbomify.com/CVE-2022-25194/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-25194
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-25194
- OSV: https://osv.dev/vulnerability/CVE-2022-25194

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-25194/
Summaries are generated and may contain mistakes; the official description above is the record.
