# CVE-2022-25195: Missing permission check in Jenkins autonomiq Plugin

> Attackers with read permissions can bypass authorization checks to connect to arbitrary URLs using specified credentials in the Jenkins Autonomiq plugin.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Feb 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-6jv7-28mv-qp9c

## What is CVE-2022-25195?

CVE-2022-25195 is a medium-severity missing authorization vulnerability in Jenkins autonomiq Plugin, published on 15 Feb 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A missing permission check in Jenkins autonomiq Plugin 1.15 and earlier allows attackers with Overall/Read permission to connect to an attacker-specified URL using attacker-specified credentials.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2022-25195?

2 open source packages ship an affected version, including io.jenkins.plugins:autonomiq. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.jenkins.plugins:autonomiq` | Maven | All versions | 1.16 |
| `io.jenkins.plugins:autonomiq` | Maven | All versions | 1.16 |

Products: Jenkins Autonomiq.

## How do I fix CVE-2022-25195?

Upgrade io.jenkins.plugins:autonomiq to 1.16 or later.

## Is CVE-2022-25195 being exploited?

There is no known exploitation of CVE-2022-25195 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins autonomiq Plugin

- [CVE-2022-25194](https://insights.sbomify.com/CVE-2022-25194/): CSRF vulnerability in Jenkins autonomiq plugin (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-25195 and fix it if it is affected.

What it is: CVE-2022-25195 is a medium-severity missing authorization vulnerability in Jenkins autonomiq Plugin, published on 15 Feb 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-25195 in the wild and no public exploit code.

Affected packages and fixed versions:
- io.jenkins.plugins:autonomiq (Maven): affected all versions; fixed in 1.16
- io.jenkins.plugins:autonomiq (Maven): affected all versions; fixed in 1.16

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-25195/ (Markdown: https://insights.sbomify.com/CVE-2022-25195/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-25195
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-25195
- OSV: https://osv.dev/vulnerability/CVE-2022-25195

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-25195/
Summaries are generated and may contain mistakes; the official description above is the record.
