{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-2522 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2022-2522 is a high-severity memory corruption vulnerability in Vim Vim, published on 25 Jul 2022. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-2522 and fix it if it is affected.\n\nWhat it is: CVE-2022-2522 is a high-severity memory corruption vulnerability in Vim Vim, published on 25 Jul 2022. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2022-2522 in the wild and no public exploit code.\n\nAffected product: Vim Vim. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-2522/ (Markdown: https://insights.sbomify.com/CVE-2022-2522/index.md)","id":"CVE-2022-2522","markdown":"https://insights.sbomify.com/CVE-2022-2522/index.md","name":"CVE-2022-2522","record":{"aliases":["AZL-10321","DEBIAN-CVE-2022-2522","GHSA-3c2j-x8m7-hrhp","UBUNTU-CVE-2022-2522","openSUSE-SU-2024:12213-1"],"analysis":{"component_type":"desktop_application","fix_type":"upgrade","impacts":["code_execution","denial_of_service"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Vim text editor","requires_auth":"none","summary":"A heap-based buffer overflow in Vim allows attackers to execute arbitrary code or cause a denial of service via crafted input.","user_interaction":"required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"@huntrdev","cpe":[{"product":"vim","vendor":"vim"}],"cvss":{"score":7.8,"severity":"high","source":"cna","vector":"CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-122","name":"Heap-based Buffer Overflow"}],"description":"Heap-based Buffer Overflow in GitHub repository vim/vim prior to 9.0.0061.","ecosystems":["openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Heap-based Buffer Overflow in vim/vim","id":"CVE-2022-2522","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"vim:vim","products":["vim:vim"],"type":"memory_corruption","year":"2022"},"n_packages":1,"n_references":5,"next":{"headline":"Cross-site Scripting (XSS) - Reflected in beancount/fava","id":"CVE-2022-2523"},"packages":[{"ecosystem":"openSUSE:Tumbleweed","fixed":["9.0.0032-1.2"],"introduced":["0"],"last_affected":[],"package":"vim","purl":"pkg:rpm/opensuse/vim\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:12213-1"}],"prev":{"headline":"Use after free in libtiff","id":"CVE-2022-2521"},"products":["vim/vim"],"published":"2022-07-25","related":[{"cvss_score":9.8,"headline":"Memory corruption in n/a","id":"CVE-2020-20703","kev_date_added":null,"published":"2023-06-20"},{"cvss_score":9.8,"headline":"Integer overflow in n/a","id":"CVE-2017-6349","kev_date_added":null,"published":"2017-02-27"},{"cvss_score":9.8,"headline":"Integer overflow in n/a","id":"CVE-2017-6350","kev_date_added":null,"published":"2017-02-27"},{"cvss_score":9.8,"headline":"Integer overflow in n/a","id":"CVE-2017-5953","kev_date_added":null,"published":"2017-02-10"},{"cvss_score":9.3,"headline":"Command injection in n/a","id":"CVE-2008-3075","kev_date_added":null,"published":"2009-02-21"},{"cvss_score":9.3,"headline":"Command injection in n/a","id":"CVE-2008-3076","kev_date_added":null,"published":"2009-02-21"},{"cvss_score":9.3,"headline":"Command injection in n/a","id":"CVE-2008-6235","kev_date_added":null,"published":"2009-02-21"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-10-08","vendors":["vim"]},"summary":"A heap-based buffer overflow in Vim allows attackers to execute arbitrary code or cause a denial of service via crafted input.","url":"https://insights.sbomify.com/CVE-2022-2522/"}