{"answers":{"affected":"2 open source packages ship an affected version, including silverstripe/framework. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-25238 in the wild and no public exploit code.","fix":"Upgrade silverstripe/framework to 4.10.9 or later.","what":"CVE-2022-25238 is a medium-severity cross-site scripting vulnerability in n/a, published on 28 Jun 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-25238 and fix it if it is affected.\n\nWhat it is: CVE-2022-25238 is a medium-severity cross-site scripting vulnerability in n/a, published on 28 Jun 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2022-25238 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- silverstripe/framework (Packagist): affected from 4.0.0; fixed in 4.10.9\n- silverstripe/framework (Packagist): affected from 4.0.0; fixed in 4.10.9\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-25238/ (Markdown: https://insights.sbomify.com/CVE-2022-25238/index.md)","id":"CVE-2022-25238","markdown":"https://insights.sbomify.com/CVE-2022-25238/index.md","name":"CVE-2022-25238","record":{"aliases":["GHSA-jx34-gqqq-r6gm"],"analysis":{"component_type":"web_application","fix_type":"configuration_change","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"Silverstripe CMS","requires_auth":"low_privilege","summary":"Authenticated CMS users can inject XSS via script tags in content if specific sanitization settings are not enabled in the Silverstripe framework.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"framework","vendor":"silverstripe"}],"cvss":{"score":5.4,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Silverstripe silverstripe/framework through 4.10.0 allows XSS, inside of script tags that can can be added to website content via XHR by an authenticated CMS user if the cwp-core module is not installed on the sanitise_server_side contig is not set to true in project code.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Stored XSS via HTML fields in SilverStripe Framework","id":"CVE-2022-25238","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2022"},"n_packages":2,"n_references":4,"next":{"headline":"Cross-site request forgery in n/a","id":"CVE-2022-25241"},"packages":[{"ecosystem":"Packagist","fixed":["4.10.9"],"introduced":["4.0.0"],"last_affected":[],"package":"silverstripe/framework","purl":null,"source":"GHSA-jx34-gqqq-r6gm"},{"ecosystem":"Packagist","fixed":["4.10.9"],"introduced":["4.0.0"],"last_affected":[],"package":"silverstripe/framework","purl":"pkg:composer/silverstripe/framework","source":"GHSA-jx34-gqqq-r6gm"}],"prev":{"headline":"Auth bypass in n/a","id":"CVE-2022-25237"},"products":["n/a"],"published":"2022-06-28","related":[{"cvss_score":8.8,"headline":"Blind SQL Injection via GridFieldSortableHeader","id":"CVE-2022-38148","kev_date_added":null,"published":"2022-11-21"},{"cvss_score":6.1,"headline":"Reflected XSS in querystring parameters","id":"CVE-2022-38462","kev_date_added":null,"published":"2022-11-22"},{"cvss_score":5.4,"headline":"Silverstripe Framework has a XSS vulnerability in HTML editor","id":"CVE-2025-30148","kev_date_added":null,"published":"2025-04-10"},{"cvss_score":5.4,"headline":"Cross-site Scripting in form messages in silverstripe framework","id":"CVE-2024-53277","kev_date_added":null,"published":"2025-01-14"},{"cvss_score":5.4,"headline":"Cross-site Scripting vulnerability with encoded payload in silverstripe/framework","id":"CVE-2024-32981","kev_date_added":null,"published":"2024-07-17"},{"cvss_score":5.4,"headline":"Silverstripe Framework has open redirect vulnerability on CMSSecurity relogin screen","id":"CVE-2023-22729","kev_date_added":null,"published":"2023-04-26"},{"cvss_score":5.4,"headline":"Stored XSS using HTMLEditor","id":"CVE-2022-37429","kev_date_added":null,"published":"2022-11-23"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["n/a"]},"summary":"Authenticated CMS users can inject XSS via script tags in content if specific sanitization settings are not enabled in the Silverstripe framework.","url":"https://insights.sbomify.com/CVE-2022-25238/"}