CVE-2022-25243 Security feature bypass in n/a
Attackers can bypass PKI subdomain restrictions to issue wildcard certificates, undermining domain validation controls in HashiCorp Vault.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-25243?
CVE-2022-25243 is a medium-severity vulnerability in Hashicorp Vault, published on 7 Mar 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
"Vault and Vault Enterprise 1.8.0 through 1.8.8, and 1.9.3 allowed the PKI secrets engine under certain configurations to issue wildcard certificates to authorized users for a specified domain, even if the PKI role policy attribute allow_subdomains is set to false. Fixed in Vault Enterprise 1.8.9 and 1.9.4.
Weakness: CWE-295
Which versions are affected by CVE-2022-25243?
1 open source package ship an affected version, including vault. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
vault Bitnami | From 1.8.0 | 1.8.9, 1.9.4 |
Products include Hashicorp Vault.
How do I fix CVE-2022-25243?
Upgrade vault to a fixed version for your release line: 1.8.9 or 1.9.4.
Is CVE-2022-25243 being exploited?
There is no known exploitation of CVE-2022-25243 in the wild and no public exploit code.
Other vulnerabilities in Hashicorp Vault
Sources
Also known as BIT-vault-2022-25243, GHSA-p3j9-qwh2-784j.