# CVE-2022-25243: Security feature bypass in n/a

> Attackers can bypass PKI subdomain restrictions to issue wildcard certificates, undermining domain validation controls in HashiCorp Vault.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Mar 2022
- **Updated:** 3 Aug 2024
- **Also known as:** BIT-vault-2022-25243, GHSA-p3j9-qwh2-784j

## What is CVE-2022-25243?

CVE-2022-25243 is a medium-severity vulnerability in Hashicorp Vault, published on 7 Mar 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

"Vault and Vault Enterprise 1.8.0 through 1.8.8, and 1.9.3 allowed the PKI secrets engine under certain configurations to issue wildcard certificates to authorized users for a specified domain, even if the PKI role policy attribute allow_subdomains is set to false. Fixed in Vault Enterprise 1.8.9 and 1.9.4.

Weakness: CWE-295 (Improper Certificate Validation)

## Which versions are affected by CVE-2022-25243?

1 open source package ship an affected version, including vault. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vault` | Bitnami | From 1.8.0 | 1.8.9, 1.9.4 |

Products: Hashicorp Vault.

## How do I fix CVE-2022-25243?

Upgrade vault to a fixed version for your release line: 1.8.9 or 1.9.4.

## Is CVE-2022-25243 being exploited?

There is no known exploitation of CVE-2022-25243 in the wild and no public exploit code.

## Other vulnerabilities in Hashicorp Vault

- [CVE-2020-35192](https://insights.sbomify.com/CVE-2020-35192/): Hardcoded credentials in n/a (critical 9.8)
- [CVE-2020-12757](https://insights.sbomify.com/CVE-2020-12757/): Improper Input Validation in HashiCorp Vault (critical 9.8)
- [CVE-2025-6000](https://insights.sbomify.com/CVE-2025-6000/): Arbitrary Remote Code Execution via Plugin Catalog Abuse (critical 9.1)
- [CVE-2022-40186](https://insights.sbomify.com/CVE-2022-40186/): HashiCorp Vault vulnerable to incorrect metadata access (critical 9.1)
- [CVE-2022-36129](https://insights.sbomify.com/CVE-2022-36129/): Missing authorization in n/a (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-25243 and fix it if it is affected.

What it is: CVE-2022-25243 is a medium-severity vulnerability in Hashicorp Vault, published on 7 Mar 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-25243 in the wild and no public exploit code.

Affected packages and fixed versions:
- vault (Bitnami): affected from 1.8.0; fixed in 1.8.9, 1.9.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-25243/ (Markdown: https://insights.sbomify.com/CVE-2022-25243/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-25243
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-25243
- OSV: https://osv.dev/vulnerability/CVE-2022-25243

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-25243/
Summaries are generated and may contain mistakes; the official description above is the record.
