CVE-2022-2527 Cross-site scripting in GitLab

High 7.3 Published Updated

An authenticated attacker can inject arbitrary content into Incident Timelines, leading to arbitrary requests when a victim interacts with it.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2022-2527?

CVE-2022-2527 is a high-severity cross-site scripting vulnerability in Gitlab Gitlab, published on 17 Oct 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

An issue in Incident Timelines has been discovered in GitLab CE/EE affecting all versions starting from 14.9 before 15.1.6, all versions starting from 15.2 before 15.2.4, all versions starting from 15.3 before 15.3.2.which allowed an authenticated attacker to inject arbitrary content. A victim interacting with this content could lead to arbitrary requests.

Weakness: CWE-79

Which versions are affected by CVE-2022-2527?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 14.9.015.1.6, 15.2.4, 15.3.2

Products include Gitlab Gitlab.

How do I fix CVE-2022-2527?

Upgrade gitlab to a fixed version for your release line: 15.1.6, 15.2.4 or 15.3.2.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2022-2527 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-2527 exists.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2022-2527, GHSA-x995-4q6w-crwj, UBUNTU-CVE-2022-2527.

Is CVE-2022-2527 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free