# CVE-2022-2529: Multiple DoS Attack Vectors in sflow packet handling

> Attackers can cause denial of service in the goflow library by sending malformed sflow packets that trigger excessive memory consumption.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Sep 2022
- **Updated:** 20 May 2025
- **Also known as:** GHSA-9rpw-2h95-666c, GO-2022-1032

## What is CVE-2022-2529?

CVE-2022-2529 is a high-severity denial of service vulnerability in Cloudflare goflow, published on 30 Sep 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

sflow decode package does not employ sufficient packet sanitisation which can lead to a denial of service attack. Attackers can craft malformed packets causing the process to consume large amounts of memory resulting in a denial of service.

Weakness: CWE-400 (Uncontrolled Resource Consumption), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2022-2529?

4 open source packages ship an affected version, including github.com/cloudflare/goflow/v3 and github.com/cloudflare/goflow. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/cloudflare/goflow/v3` | Go | All versions | 3.4.4 |
| `github.com/cloudflare/goflow/v3` | Go | All versions | 3.4.4 |
| `github.com/cloudflare/goflow/v3` | Go | All versions | 3.4.4 |
| `github.com/cloudflare/goflow` | Go | All versions | None |

Products: Cloudflare Goflow.

## How do I fix CVE-2022-2529?

Upgrade github.com/cloudflare/goflow/v3 to 3.4.4 or later.

## Is CVE-2022-2529 being exploited?

There is no known exploitation of CVE-2022-2529 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-2529 and fix it if it is affected.

What it is: CVE-2022-2529 is a high-severity denial of service vulnerability in Cloudflare goflow, published on 30 Sep 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-2529 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/cloudflare/goflow/v3 (Go): affected all versions; fixed in 3.4.4
- github.com/cloudflare/goflow/v3 (Go): affected all versions; fixed in 3.4.4
- github.com/cloudflare/goflow/v3 (Go): affected all versions; fixed in 3.4.4
- github.com/cloudflare/goflow (Go): affected all versions; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-2529/ (Markdown: https://insights.sbomify.com/CVE-2022-2529/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-2529
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-2529
- OSV: https://osv.dev/vulnerability/CVE-2022-2529

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-2529/
Summaries are generated and may contain mistakes; the official description above is the record.
