# CVE-2022-25294: Privilege escalation in n/a

> Unprivileged local users can execute arbitrary code with SYSTEM privileges via a dangerous function in the Proofpoint Windows agent.

- **Severity:** High 7.8 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 7 Mar 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-xq7x-c5pr-rfg4

## What is CVE-2022-25294?

CVE-2022-25294 is a high-severity vulnerability in n/a, published on 7 Mar 2022. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Proofpoint Insider Threat Management Agent for Windows relies on an inherently dangerous function that could enable an unprivileged local Windows user to run arbitrary code with SYSTEM privileges. All versions prior to 7.12.1 are affected. Agents for MacOS and Linux and Cloud are unaffected. Proofpoint has released fixed software version 7.12.1. The fixed software versions are available through the customer support portal.

## Which versions are affected by CVE-2022-25294?

It affects 1 product.


Products: Proofpoint Insider Threat Management.

## How do I fix CVE-2022-25294?

No fix has been published for CVE-2022-25294 yet. Limit exposure of the affected software until one is available.

## Is CVE-2022-25294 being exploited?

There is no known exploitation of CVE-2022-25294 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2020-8884](https://insights.sbomify.com/CVE-2020-8884/): Deserialization in n/a (high 8.8)
- [CVE-2021-27900](https://insights.sbomify.com/CVE-2021-27900/): Missing authorization in n/a (high 8.1)
- [CVE-2021-22159](https://insights.sbomify.com/CVE-2021-22159/): Missing authorization in n/a (high 7.8)
- [CVE-2023-4801](https://insights.sbomify.com/CVE-2023-4801/): ITM MacOS Agent Improper Certificate Validation (high 7.5)
- [CVE-2021-27899](https://insights.sbomify.com/CVE-2021-27899/): Weak cryptography in n/a (high 7.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-25294 and fix it if it is affected.

What it is: CVE-2022-25294 is a high-severity vulnerability in n/a, published on 7 Mar 2022. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-25294 in the wild and no public exploit code.

Affected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-25294/ (Markdown: https://insights.sbomify.com/CVE-2022-25294/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-25294
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-25294
- OSV: https://osv.dev/vulnerability/CVE-2022-25294

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-25294/
Summaries are generated and may contain mistakes; the official description above is the record.
