{"answers":{"affected":"3 open source packages ship an affected version, including whoogle-search. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-25303 in the wild and no public exploit code.","fix":"Upgrade whoogle-search to 0.7.2 or later.","what":"CVE-2022-25303 is a medium-severity cross-site scripting vulnerability in whoogle-search, published on 12 Jul 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-25303 and fix it if it is affected.\n\nWhat it is: CVE-2022-25303 is a medium-severity cross-site scripting vulnerability in whoogle-search, published on 12 Jul 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2022-25303 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- whoogle-search (PyPI): affected all versions; fixed in 0.7.2\n- whoogle-search (PyPI): affected all versions; fixed in 0.7.2\n- whoogle-search (PyPI): affected all versions; fixed in 0.7.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-25303/ (Markdown: https://insights.sbomify.com/CVE-2022-25303/index.md)","id":"CVE-2022-25303","markdown":"https://insights.sbomify.com/CVE-2022-25303/index.md","name":"CVE-2022-25303","record":{"aliases":["GHSA-mxvc-fwgx-j778","PYSEC-2022-226","SNYK-PYTHON-WHOOGLESEARCH-2803306"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Whoogle Search","requires_auth":"none","summary":"Attacker can execute arbitrary JavaScript in victim's browser via unescaped query parameter in Whoogle Search error messages.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"snyk","cpe":[{"product":"whoogle-search","vendor":"whoogle-search_project"}],"cvss":{"score":5.4,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N/E:P","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"The package whoogle-search before 0.7.2 are vulnerable to Cross-site Scripting (XSS) via the query string parameter q. In the case where it does not contain the http string, it is used to build the error_message that is then rendered in the error.html template, using the [flask.render_template](https://flask.palletsprojects.com/en/2.1.x/api/flask.render_template) function. However, the error_message is rendered using the [| safe filter](https://jinja.palletsprojects.com/en/3.1.x/templates/working-with-automatic-escaping), meaning the user input is not escaped.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cross-site Scripting (XSS)","id":"CVE-2022-25303","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"xss","year":"2022"},"n_packages":3,"n_references":3,"next":{"headline":"Denial of Service (DoS)","id":"CVE-2022-25304"},"packages":[{"ecosystem":"PyPI","fixed":["0.7.2"],"introduced":["0"],"last_affected":[],"package":"whoogle-search","purl":null,"source":"GHSA-mxvc-fwgx-j778"},{"ecosystem":"PyPI","fixed":["0.7.2"],"introduced":["0"],"last_affected":[],"package":"whoogle-search","purl":"pkg:pypi/whoogle-search","source":"GHSA-mxvc-fwgx-j778"},{"ecosystem":"PyPI","fixed":["0.7.2"],"introduced":["0"],"last_affected":[],"package":"whoogle-search","purl":"pkg:pypi/whoogle-search","source":"PYSEC-2022-226"}],"prev":{"headline":"Denial of Service (DoS)","id":"CVE-2022-25302"},"products":["whoogle-search"],"published":"2022-07-12","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["n/a"]},"summary":"Attacker can execute arbitrary JavaScript in victim's browser via unescaped query parameter in Whoogle Search error messages.","url":"https://insights.sbomify.com/CVE-2022-25303/"}