{"answers":{"affected":"6 open source packages ship an affected version, including asyncua and opcua. It affects 2 products.","exploited":"There is no known exploitation of CVE-2022-25304 in the wild and no public exploit code.","fix":"Upgrade asyncua to 0.9.96 or later.","what":"CVE-2022-25304 is a high-severity denial of service vulnerability in asyncua, published on 23 Aug 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-25304 and fix it if it is affected.\n\nWhat it is: CVE-2022-25304 is a high-severity denial of service vulnerability in asyncua, published on 23 Aug 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-25304 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- asyncua (PyPI): affected all versions; fixed in 0.9.96\n- asyncua (PyPI): affected all versions; fixed in 0.9.96\n- asyncua (PyPI): affected all versions; fixed in 0.9.96\n- opcua (PyPI): affected all versions up to 0.98.13; no fix listed\n- opcua (PyPI): affected all versions up to 0.98.13; no fix listed\n- opcua (PyPI): affected all versions up to 0.98.13; no fix listed\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-25304/ (Markdown: https://insights.sbomify.com/CVE-2022-25304/index.md)","id":"CVE-2022-25304","markdown":"https://insights.sbomify.com/CVE-2022-25304/index.md","name":"CVE-2022-25304","record":{"aliases":["DEBIAN-CVE-2022-25304","GHSA-mfpj-3qhm-976m","PYSEC-2026-2385","PYSEC-2026-888","UBUNTU-CVE-2022-25304"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Python OPC UA library","requires_auth":"none","summary":"An attacker can cause a denial of service by sending unlimited large chunks without closing them, exhausting resources in the asyncua library.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"snyk","cpe":[{"product":"asyncua","vendor":"asyncua_project"},{"product":"opcua","vendor":"opcua_project"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H/E:P","version":"3.1"},"cwes":[{"id":"CWE-770","name":"Allocation of Resources Without Limits or Throttling"}],"description":"All versions of package opcua; all versions of package asyncua are vulnerable to Denial of Service (DoS) due to a missing limitation on the number of received chunks - per single session or in total for all concurrent sessions. An attacker can exploit this vulnerability by sending an unlimited number of huge chunks (e.g. 2GB each) without sending the Final closing chunk.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Denial of Service (DoS)","id":"CVE-2022-25304","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"denial_of_service","year":"2022"},"n_packages":6,"n_references":3,"next":{"headline":"WP Statistics \u003c= 13.1.5 Unauthenticated Stored Cross-Site Scripting via IP","id":"CVE-2022-25305"},"packages":[{"ecosystem":"PyPI","fixed":["0.9.96"],"introduced":["0"],"last_affected":[],"package":"asyncua","purl":null,"source":"GHSA-mfpj-3qhm-976m"},{"ecosystem":"PyPI","fixed":["0.9.96"],"introduced":["0"],"last_affected":[],"package":"asyncua","purl":"pkg:pypi/asyncua","source":"GHSA-mfpj-3qhm-976m"},{"ecosystem":"PyPI","fixed":["0.9.96"],"introduced":["0"],"last_affected":[],"package":"asyncua","purl":"pkg:pypi/asyncua","source":"PYSEC-2026-2385"},{"ecosystem":"PyPI","fixed":[],"introduced":["0"],"last_affected":["0.98.13"],"package":"opcua","purl":null,"source":"GHSA-mfpj-3qhm-976m"},{"ecosystem":"PyPI","fixed":[],"introduced":["0"],"last_affected":["0.98.13"],"package":"opcua","purl":"pkg:pypi/opcua","source":"GHSA-mfpj-3qhm-976m"},{"ecosystem":"PyPI","fixed":[],"introduced":["0"],"last_affected":["0.98.13"],"package":"opcua","purl":"pkg:pypi/opcua","source":"PYSEC-2026-888"}],"prev":{"headline":"Cross-site Scripting (XSS)","id":"CVE-2022-25303"},"products":["asyncua","opcua"],"published":"2022-08-23","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-17","vendors":["n/a"]},"summary":"An attacker can cause a denial of service by sending unlimited large chunks without closing them, exhausting resources in the asyncua library.","url":"https://insights.sbomify.com/CVE-2022-25304/"}