# CVE-2022-25312: An XML external entity (XXE) injection vulnerability exists in the Apache Any23 RDFa XSLTStylesheet extractor

> An XXE vulnerability in Apache Any23 allows attackers to read server files and interact with backend systems via crafted XML data.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Mar 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-2rmm-87v7-34rj

## What is CVE-2022-25312?

CVE-2022-25312 is a critical vulnerability in Apache Any23, published on 4 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An XML external entity (XXE) injection vulnerability was discovered in the Any23 RDFa XSLTStylesheet extractor and is known to affect Any23 versions < 2.7. XML external entity injection (also known as XXE) is a web security vulnerability that allows an attacker to interfere with an application's processing of XML data. It often allows an attacker to view files on the application server filesystem, and to interact with any back-end or external systems that the application itself can access. This issue is fixed in Apache Any23 2.7.

Weakness: CWE-611 (Improper Restriction of XML External Entity Reference)

## Which versions are affected by CVE-2022-25312?

2 open source packages ship an affected version, including org.apache.any23:apache-any23. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.any23:apache-any23` | Maven | All versions | 2.7 |
| `org.apache.any23:apache-any23` | Maven | All versions | 2.7 |

Products: Apache Any23.

## How do I fix CVE-2022-25312?

Upgrade org.apache.any23:apache-any23 to 2.7 or later.

## Is CVE-2022-25312 being exploited?

There is no known exploitation of CVE-2022-25312 in the wild and no public exploit code.

## Other vulnerabilities in Apache Any23

- [CVE-2021-40146](https://insights.sbomify.com/CVE-2021-40146/): A Remote Code Execution (RCE) vulnerability exists in Apache Any23 YAMLExtractor.java (critical 9.8)
- [CVE-2021-38555](https://insights.sbomify.com/CVE-2021-38555/): An XML external entity (XXE) injection vulnerability exists in Apache Any23 StreamUtils.java (critical 9.1)
- [CVE-2023-34150](https://insights.sbomify.com/CVE-2023-34150/): Apache Any23: Possible excessive allocation of resources reading input. (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-25312 and fix it if it is affected.

What it is: CVE-2022-25312 is a critical vulnerability in Apache Any23, published on 4 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-25312 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.any23:apache-any23 (Maven): affected all versions; fixed in 2.7
- org.apache.any23:apache-any23 (Maven): affected all versions; fixed in 2.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-25312/ (Markdown: https://insights.sbomify.com/CVE-2022-25312/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-25312
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-25312
- OSV: https://osv.dev/vulnerability/CVE-2022-25312

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-25312/
Summaries are generated and may contain mistakes; the official description above is the record.
