# CVE-2022-25326: Denial of Service in fscrypt

> Unprivileged users can exhaust filesystem space because fscrypt creates world-writable directories by default during setup.

- **Severity:** Medium 5.5 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Feb 2022
- **Updated:** 21 Apr 2025
- **Also known as:** DEBIAN-CVE-2022-25326, GHSA-chxf-fjcf-7fwp, GHSA-mpq4-rjj8-fjph, GO-2022-0339, UBUNTU-CVE-2022-25326

## What is CVE-2022-25326?

CVE-2022-25326 is a medium-severity denial of service vulnerability in Google LLC fscrypt, published on 25 Feb 2022. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

fscrypt through v0.3.2 creates a world-writable directory by default when setting up a filesystem, allowing unprivileged users to exhaust filesystem space. We recommend upgrading to fscrypt 0.3.3 or above and adjusting the permissions on existing fscrypt metadata directories where applicable.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2022-25326?

5 open source packages ship an affected version, including github.com/google/fscrypt. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/google/fscrypt` | Go | All versions | 0.3.3 |
| `github.com/google/fscrypt` | Go | All versions | 0.3.3 |
| `github.com/google/fscrypt` | Go | All versions | 0.3.3 |
| `github.com/google/fscrypt` | Go | All versions | 0.3.3 |
| `github.com/google/fscrypt` | Go | All versions | 0.3.3 |

Products: Google Fscrypt.

## How do I fix CVE-2022-25326?

Upgrade github.com/google/fscrypt to 0.3.3 or later.

## Is CVE-2022-25326 being exploited?

There is no known exploitation of CVE-2022-25326 in the wild and no public exploit code.

## Other vulnerabilities in Google LLC fscrypt

- [CVE-2018-6558](https://insights.sbomify.com/CVE-2018-6558/): Privilege Escalation in fscrypt (medium 6.5)
- [CVE-2022-25327](https://insights.sbomify.com/CVE-2022-25327/): Local Denial of Service in fscrypt PAM module (medium 5.5)
- [CVE-2022-25328](https://insights.sbomify.com/CVE-2022-25328/): Privilege escalation through command injection in fscrypt (medium 5.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-25326 and fix it if it is affected.

What it is: CVE-2022-25326 is a medium-severity denial of service vulnerability in Google LLC fscrypt, published on 25 Feb 2022. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-25326 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/google/fscrypt (Go): affected all versions; fixed in 0.3.3
- github.com/google/fscrypt (Go): affected all versions; fixed in 0.3.3
- github.com/google/fscrypt (Go): affected all versions; fixed in 0.3.3
- github.com/google/fscrypt (Go): affected all versions; fixed in 0.3.3
- github.com/google/fscrypt (Go): affected all versions; fixed in 0.3.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-25326/ (Markdown: https://insights.sbomify.com/CVE-2022-25326/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-25326
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-25326
- OSV: https://osv.dev/vulnerability/CVE-2022-25326

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-25326/
Summaries are generated and may contain mistakes; the official description above is the record.
