{"answers":{"affected":"5 open source packages ship an affected version, including github.com/google/fscrypt. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-25327 in the wild and no public exploit code.","fix":"Upgrade github.com/google/fscrypt to 0.3.3 or later.","what":"CVE-2022-25327 is a medium-severity denial of service vulnerability in Google LLC fscrypt, published on 25 Feb 2022. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-25327 and fix it if it is affected.\n\nWhat it is: CVE-2022-25327 is a medium-severity denial of service vulnerability in Google LLC fscrypt, published on 25 Feb 2022. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-25327 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- github.com/google/fscrypt (Go): affected all versions; fixed in 0.3.3\n- github.com/google/fscrypt (Go): affected all versions; fixed in 0.3.3\n- github.com/google/fscrypt (Go): affected all versions; fixed in 0.3.3\n- github.com/google/fscrypt (Go): affected all versions; fixed in 0.3.3\n- github.com/google/fscrypt (Go): affected all versions; fixed in 0.3.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-25327/ (Markdown: https://insights.sbomify.com/CVE-2022-25327/index.md)","id":"CVE-2022-25327","markdown":"https://insights.sbomify.com/CVE-2022-25327/index.md","name":"CVE-2022-25327","record":{"aliases":["DEBIAN-CVE-2022-25327","GHSA-8vwm-8vj8-rqjf","GHSA-p93v-m2r2-4387","GO-2022-0340","UBUNTU-CVE-2022-25327"],"analysis":{"component_type":"operating_system","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Linux PAM module","requires_auth":"low_privilege","summary":"A local attacker can create malicious metadata files to prevent other users from logging in, causing a denial of service.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Google","cpe":[{"product":"fscrypt","vendor":"google"}],"cvss":{"score":5.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-276","name":"Incorrect Default Permissions"},{"id":"CWE-255","name":null}],"description":"The PAM module for fscrypt doesn't adequately validate fscrypt metadata files, allowing users to create malicious metadata files that prevent other users from logging in. A local user can cause a denial of service by creating a fscrypt metadata file that prevents other users from logging into the system. We recommend upgrading to version 0.3.3 or above","ecosystems":["Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Local Denial of Service in fscrypt PAM module","id":"CVE-2022-25327","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":null,"products":[],"type":"denial_of_service","year":"2022"},"n_packages":5,"n_references":1,"next":{"headline":"Privilege escalation through command injection in fscrypt","id":"CVE-2022-25328"},"packages":[{"ecosystem":"Go","fixed":["0.3.3"],"introduced":["0"],"last_affected":[],"package":"github.com/google/fscrypt","purl":null,"source":"GHSA-8vwm-8vj8-rqjf"},{"ecosystem":"Go","fixed":["0.3.3"],"introduced":["0"],"last_affected":[],"package":"github.com/google/fscrypt","purl":"pkg:golang/github.com/google/fscrypt","source":"GHSA-8vwm-8vj8-rqjf"},{"ecosystem":"Go","fixed":["0.3.3"],"introduced":["0"],"last_affected":[],"package":"github.com/google/fscrypt","purl":null,"source":"GHSA-p93v-m2r2-4387"},{"ecosystem":"Go","fixed":["0.3.3"],"introduced":["0"],"last_affected":[],"package":"github.com/google/fscrypt","purl":"pkg:golang/github.com/google/fscrypt","source":"GHSA-p93v-m2r2-4387"},{"ecosystem":"Go","fixed":["0.3.3"],"introduced":["0"],"last_affected":[],"package":"github.com/google/fscrypt","purl":"pkg:golang/github.com/google/fscrypt","source":"GO-2022-0340"}],"prev":{"headline":"Denial of Service in fscrypt","id":"CVE-2022-25326"},"products":["fscrypt"],"published":"2022-02-25","related":[{"cvss_score":6.5,"headline":"Privilege Escalation in fscrypt","id":"CVE-2018-6558","kev_date_added":null,"published":"2018-08-23"},{"cvss_score":5.5,"headline":"Denial of Service in fscrypt","id":"CVE-2022-25326","kev_date_added":null,"published":"2022-02-25"},{"cvss_score":5,"headline":"Privilege escalation through command injection in fscrypt","id":"CVE-2022-25328","kev_date_added":null,"published":"2022-02-25"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-21","vendors":["Google LLC"]},"summary":"A local attacker can create malicious metadata files to prevent other users from logging in, causing a denial of service.","url":"https://insights.sbomify.com/CVE-2022-25327/"}