{"answers":{"affected":"2 open source packages ship an affected version, including github.com/google/fscrypt. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-25328 in the wild and no public exploit code.","fix":"Upgrade github.com/google/fscrypt to 0.3.3 or later.","what":"CVE-2022-25328 is a medium-severity command injection vulnerability in Google LLC fscrypt, published on 25 Feb 2022. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-25328 and fix it if it is affected.\n\nWhat it is: CVE-2022-25328 is a medium-severity command injection vulnerability in Google LLC fscrypt, published on 25 Feb 2022. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2022-25328 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- github.com/google/fscrypt (Go): affected all versions; fixed in 0.3.3\n- github.com/google/fscrypt (Go): affected all versions; fixed in 0.3.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-25328/ (Markdown: https://insights.sbomify.com/CVE-2022-25328/index.md)","id":"CVE-2022-25328","markdown":"https://insights.sbomify.com/CVE-2022-25328/index.md","name":"CVE-2022-25328","record":{"aliases":["DEBIAN-CVE-2022-25328","GHSA-wxjg-p59j-6c92"],"analysis":{"component_type":"operating_system","fix_type":"upgrade","impacts":["privilege_escalation","code_execution"],"network_reachable":"adjacent_or_local","non_default_config":true,"product_category":"Linux disk encryption tool","requires_auth":"low_privilege","summary":"Local attackers can escalate privileges via command injection in fscrypt's bash completion script if administrators use it on malicious mountpoints.","user_interaction":"required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Google","cpe":[{"product":"fscrypt","vendor":"google"}],"cvss":{"score":5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-78","name":"Improper Neutralization of Special Elements used in an OS Command"}],"description":"The bash_completion script for fscrypt allows injection of commands via crafted mountpoint paths, allowing privilege escalation under a specific set of circumstances. A local user who has control over mountpoint paths could potentially escalate their privileges if they create a malicious mountpoint path and if the system administrator happens to be using the fscrypt bash completion script to complete mountpoint paths. We recommend upgrading to version 0.3.3 or above","ecosystems":["Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Privilege escalation through command injection in fscrypt","id":"CVE-2022-25328","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":null,"products":[],"type":"command_injection","year":"2022"},"n_packages":2,"n_references":1,"next":{"headline":"Hardcoded credentials in Trend Micro ServerProtect for EMC Celerra","id":"CVE-2022-25329"},"packages":[{"ecosystem":"Go","fixed":["0.3.3"],"introduced":["0"],"last_affected":[],"package":"github.com/google/fscrypt","purl":null,"source":"GHSA-wxjg-p59j-6c92"},{"ecosystem":"Go","fixed":["0.3.3"],"introduced":["0"],"last_affected":[],"package":"github.com/google/fscrypt","purl":"pkg:golang/github.com/google/fscrypt","source":"GHSA-wxjg-p59j-6c92"}],"prev":{"headline":"Local Denial of Service in fscrypt PAM module","id":"CVE-2022-25327"},"products":["fscrypt"],"published":"2022-02-25","related":[{"cvss_score":6.5,"headline":"Privilege Escalation in fscrypt","id":"CVE-2018-6558","kev_date_added":null,"published":"2018-08-23"},{"cvss_score":5.5,"headline":"Denial of Service in fscrypt","id":"CVE-2022-25326","kev_date_added":null,"published":"2022-02-25"},{"cvss_score":5.5,"headline":"Local Denial of Service in fscrypt PAM module","id":"CVE-2022-25327","kev_date_added":null,"published":"2022-02-25"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-21","vendors":["Google LLC"]},"summary":"Local attackers can escalate privileges via command injection in fscrypt's bash completion script if administrators use it on malicious mountpoints.","url":"https://insights.sbomify.com/CVE-2022-25328/"}