# CVE-2022-25336: Exposure of Resource to Wrong Sphere in ezsystems/ezplatform-kernel

> Attackers can access unauthorized image files by deducing predictable paths and filenames in Ibexa DXP.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Feb 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-x8xx-x82q-42q3

## What is CVE-2022-25336?

CVE-2022-25336 is a medium-severity vulnerability in n/a, published on 18 Feb 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Ibexa DXP ezsystems/ezpublish-kernel 7.5.x before 7.5.26 and 1.3.x before 1.3.12 allows Insecure Direct Object Reference (IDOR) attacks against image files because the image path and filename can be correctly deduced.

Weakness: CWE-639 (Authorization Bypass Through User-Controlled Key)

## Which versions are affected by CVE-2022-25336?

2 open source packages ship an affected version, including ezsystems/ezplatform-kernel. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ezsystems/ezplatform-kernel` | Packagist | From 1.3.0 | 1.3.12 |
| `ezsystems/ezplatform-kernel` | Packagist | From 1.3.0 | 1.3.12 |

Products: Ibexa Ez Platform Kernel.

## How do I fix CVE-2022-25336?

Upgrade ezsystems/ezplatform-kernel to 1.3.12 or later.

## Is CVE-2022-25336 being exploited?

There is no known exploitation of CVE-2022-25336 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2022-25337](https://insights.sbomify.com/CVE-2022-25337/): Code injection in ezsystems/ezpublish-kernel (critical 9.8)
- [CVE-2021-46875](https://insights.sbomify.com/CVE-2021-46875/): Cross-site scripting in eZ Platform Kernel (medium 6.1)
- [CVE-2021-46876](https://insights.sbomify.com/CVE-2021-46876/): /user/sessions endpoint allows detecting valid accounts (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-25336 and fix it if it is affected.

What it is: CVE-2022-25336 is a medium-severity vulnerability in n/a, published on 18 Feb 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-25336 in the wild and no public exploit code.

Affected packages and fixed versions:
- ezsystems/ezplatform-kernel (Packagist): affected from 1.3.0; fixed in 1.3.12
- ezsystems/ezplatform-kernel (Packagist): affected from 1.3.0; fixed in 1.3.12

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-25336/ (Markdown: https://insights.sbomify.com/CVE-2022-25336/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-25336
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-25336
- OSV: https://osv.dev/vulnerability/CVE-2022-25336

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-25336/
Summaries are generated and may contain mistakes; the official description above is the record.
