# CVE-2022-25337: Code injection in ezsystems/ezpublish-kernel

> Attackers can execute arbitrary code by exploiting injection flaws in image filename handling within the Ibexa DXP platform.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Feb 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-xwv6-v7qx-f5jc

## What is CVE-2022-25337?

CVE-2022-25337 is a critical code injection vulnerability in n/a, published on 18 Feb 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Ibexa DXP ezsystems/ezpublish-kernel 7.5.x before 7.5.26 and 1.3.x before 1.3.12 allows injection attacks via image filenames.

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component)

## Which versions are affected by CVE-2022-25337?

2 open source packages ship an affected version, including ezsystems/ezpublish-kernel. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ezsystems/ezpublish-kernel` | Packagist | From 7.5.0 | 7.5.26 |
| `ezsystems/ezpublish-kernel` | Packagist | From 7.5.0 | 7.5.26 |

Products: Ibexa Ez Platform Kernel.

## How do I fix CVE-2022-25337?

Upgrade ezsystems/ezpublish-kernel to 7.5.26 or later.

## Is CVE-2022-25337 being exploited?

There is no known exploitation of CVE-2022-25337 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2021-46875](https://insights.sbomify.com/CVE-2021-46875/): Cross-site scripting in eZ Platform Kernel (medium 6.1)
- [CVE-2021-46876](https://insights.sbomify.com/CVE-2021-46876/): /user/sessions endpoint allows detecting valid accounts (medium 5.3)
- [CVE-2022-25336](https://insights.sbomify.com/CVE-2022-25336/): Exposure of Resource to Wrong Sphere in ezsystems/ezplatform-kernel (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-25337 and fix it if it is affected.

What it is: CVE-2022-25337 is a critical code injection vulnerability in n/a, published on 18 Feb 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-25337 in the wild and no public exploit code.

Affected packages and fixed versions:
- ezsystems/ezpublish-kernel (Packagist): affected from 7.5.0; fixed in 7.5.26
- ezsystems/ezpublish-kernel (Packagist): affected from 7.5.0; fixed in 7.5.26

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-25337/ (Markdown: https://insights.sbomify.com/CVE-2022-25337/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-25337
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-25337
- OSV: https://osv.dev/vulnerability/CVE-2022-25337

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-25337/
Summaries are generated and may contain mistakes; the official description above is the record.
