# CVE-2022-25354: Prototype Pollution

> Prototype pollution in the set-in library allows attackers to modify object prototypes, potentially leading to code execution or privilege escalation.

- **Severity:** High 8.6 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:H/A:L/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Mar 2022
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-6956-83fg-5wc5, SNYK-JS-SETIN-2388571

## What is CVE-2022-25354?

CVE-2022-25354 is a high-severity vulnerability in set-in, published on 17 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The package set-in before 2.0.3 are vulnerable to Prototype Pollution via the setIn method, as it allows an attacker to merge object prototypes into it. **Note:** This vulnerability derives from an incomplete fix of [CVE-2020-28273](https://security.snyk.io/vuln/SNYK-JS-SETIN-1048049)

Weakness: CWE-1321 (Improperly Controlled Modification of Object Prototype Attributes)

## Which versions are affected by CVE-2022-25354?

2 open source packages ship an affected version, including set-in. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `set-in` | npm | All versions | 2.0.3 |
| `set-in` | npm | All versions | 2.0.3 |

Products: Set-in Project Set-In.

## How do I fix CVE-2022-25354?

Upgrade set-in to 2.0.3 or later.

## Is CVE-2022-25354 being exploited?

There is no known exploitation of CVE-2022-25354 in the wild and no public exploit code.

## Other vulnerabilities in set-in

- [CVE-2020-28273](https://insights.sbomify.com/CVE-2020-28273/): Prototype pollution in set-in (critical 9.8)
- [CVE-2026-26021](https://insights.sbomify.com/CVE-2026-26021/): Prototype pollution in set-in (critical 9.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-25354 and fix it if it is affected.

What it is: CVE-2022-25354 is a high-severity vulnerability in set-in, published on 17 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-25354 in the wild and no public exploit code.

Affected packages and fixed versions:
- set-in (npm): affected all versions; fixed in 2.0.3
- set-in (npm): affected all versions; fixed in 2.0.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-25354/ (Markdown: https://insights.sbomify.com/CVE-2022-25354/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-25354
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-25354
- OSV: https://osv.dev/vulnerability/CVE-2022-25354

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-25354/
Summaries are generated and may contain mistakes; the official description above is the record.
