# CVE-2022-25355: EC-CUBE improperly handles HTTP Host header values

> Remote attackers can exploit improper Host header handling to send forged password reset emails, potentially leading to account takeover.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Feb 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-pw97-6v74-9w3p

## What is CVE-2022-25355?

CVE-2022-25355 is a medium-severity vulnerability in EC-CUBE 3 series and EC-CUBE 4 series, published on 24 Feb 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

EC-CUBE 3.0.0 to 3.0.18-p3 and EC-CUBE 4.0.0 to 4.1.1 improperly handle HTTP Host header values, which may lead a remote unauthenticated attacker to direct the vulnerable version of EC-CUBE to send an Email with some forged reissue-password URL to EC-CUBE users.

Weakness: CWE-913 (Improper Control of Dynamically-Managed Code Resources)

## Which versions are affected by CVE-2022-25355?

4 open source packages ship an affected version, including ec-cube/ec-cube. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ec-cube/ec-cube` | Packagist | From 3.0.0 to 3.0.18-p3 | None |
| `ec-cube/ec-cube` | Packagist | From 3.0.0 to 3.0.18-p3 | None |
| `ec-cube/ec-cube` | Packagist | From 4.0.0 | 4.1.2 |
| `ec-cube/ec-cube` | Packagist | From 4.0.0 | 4.1.2 |

Products: Ec-Cube Ec-Cube.

## How do I fix CVE-2022-25355?

Upgrade ec-cube/ec-cube to 4.1.2 or later.

## Is CVE-2022-25355 being exploited?

There is no known exploitation of CVE-2022-25355 in the wild and no public exploit code.

## Other vulnerabilities in EC-CUBE 3 series and EC-CUBE 4 series

- [CVE-2020-5590](https://insights.sbomify.com/CVE-2020-5590/): EC-CUBE Directory traversal vulnerability (high 8.1)
- [CVE-2021-20778](https://insights.sbomify.com/CVE-2021-20778/): Missing authorization in EC-CUBE (high 7.5)
- [CVE-2020-5680](https://insights.sbomify.com/CVE-2020-5680/): EC-CUBE Improper input validation vulnerability (high 7.5)
- [CVE-2008-4991](https://insights.sbomify.com/CVE-2008-4991/): SQL injection in n/a (high 7.5)
- [CVE-2008-4534](https://insights.sbomify.com/CVE-2008-4534/): SQL injection in n/a (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-25355 and fix it if it is affected.

What it is: CVE-2022-25355 is a medium-severity vulnerability in EC-CUBE 3 series and EC-CUBE 4 series, published on 24 Feb 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-25355 in the wild and no public exploit code.

Affected packages and fixed versions:
- ec-cube/ec-cube (Packagist): affected from 3.0.0 up to 3.0.18-p3; no fix listed
- ec-cube/ec-cube (Packagist): affected from 3.0.0 up to 3.0.18-p3; no fix listed
- ec-cube/ec-cube (Packagist): affected from 4.0.0; fixed in 4.1.2
- ec-cube/ec-cube (Packagist): affected from 4.0.0; fixed in 4.1.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-25355/ (Markdown: https://insights.sbomify.com/CVE-2022-25355/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-25355
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-25355
- OSV: https://osv.dev/vulnerability/CVE-2022-25355

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-25355/
Summaries are generated and may contain mistakes; the official description above is the record.
