# CVE-2022-25508: Improper Authentication in FreeTAKServer

> Unauthenticated attackers can cause denial of service or inject false routes in FreeTAKServer due to missing access controls on route creation.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Mar 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-hggv-mcp4-vxc5, PYSEC-2022-43054

## What is CVE-2022-25508?

CVE-2022-25508 is a high-severity missing authorization vulnerability in n/a, published on 10 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An access control issue in the component /ManageRoute/postRoute of FreeTAKServer v1.9.8 allows unauthenticated attackers to cause a Denial of Service (DoS) via an unusually large amount of created routes, or create unsafe or false routes for legitimate users.

Weakness: CWE-306 (Missing Authentication for Critical Functionality)

## Which versions are affected by CVE-2022-25508?

3 open source packages ship an affected version, including freetakserver and FreeTAKServer. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `freetakserver` | PyPI | All versions | None |
| `freetakserver` | PyPI | All versions | 1.9.8.5 |
| `FreeTAKServer` | PyPI | All versions | 1.9.8.5 |

Products: Freetakserver-Ui Project Freetakserver-Ui.

## How do I fix CVE-2022-25508?

Upgrade freetakserver to 1.9.8.5 or later.

## Is CVE-2022-25508 being exploited?

There is no known exploitation of CVE-2022-25508 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2022-25510](https://insights.sbomify.com/CVE-2022-25510/): Hard coded credentials in FreeTAKServer (high 8.8)
- [CVE-2022-25512](https://insights.sbomify.com/CVE-2022-25512/): Exposure of Sensitive Information to an Unauthorized Actor in FreeTAKServer-UI (high 7.5)
- [CVE-2022-25506](https://insights.sbomify.com/CVE-2022-25506/): SQL Injection in FreeTAKServer-UI (medium 6.5)
- [CVE-2022-25511](https://insights.sbomify.com/CVE-2022-25511/): Path traversal in FreeTAKServer-UI (medium 6.5)
- [CVE-2022-25507](https://insights.sbomify.com/CVE-2022-25507/): Cross-site Scripting in FreeTAKServer-UI (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-25508 and fix it if it is affected.

What it is: CVE-2022-25508 is a high-severity missing authorization vulnerability in n/a, published on 10 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-25508 in the wild and no public exploit code.

Affected packages and fixed versions:
- freetakserver (PyPI): affected all versions; no fix listed
- freetakserver (PyPI): affected all versions; fixed in 1.9.8.5
- FreeTAKServer (PyPI): affected all versions; fixed in 1.9.8.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-25508/ (Markdown: https://insights.sbomify.com/CVE-2022-25508/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-25508
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-25508
- OSV: https://osv.dev/vulnerability/CVE-2022-25508

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-25508/
Summaries are generated and may contain mistakes; the official description above is the record.
