# CVE-2022-25568: MotionEye allows attackers to access sensitive information

> Attackers can access sensitive configuration data via an unauthenticated GET request if the regular user password is not configured.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Mar 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-2c7w-v459-cwgf, PYSEC-2022-43141

## What is CVE-2022-25568?

CVE-2022-25568 is a high-severity vulnerability in n/a, published on 24 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

MotionEye v0.42.1 and below allows attackers to access sensitive information via a GET request to /config/list. To exploit this vulnerability, a regular user password must be unconfigured.

Weakness: CWE-1188 (Initialization of a Resource with an Insecure Default)

## Which versions are affected by CVE-2022-25568?

3 open source packages ship an affected version, including motioneye. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `motioneye` | PyPI | All versions | 0.43.1b1 |
| `motioneye` | PyPI | All versions | 0.43.1b1 |
| `motioneye` | PyPI | All versions | 0.43.1b1 |

Products: Motioneye Project Motioneye.

## How do I fix CVE-2022-25568?

Upgrade motioneye to 0.43.1b1 or later.

## Is CVE-2022-25568 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-25568 exists.

Public exploit code:

- MotionEye Config Info Disclosure (nuclei): http/cves/2022/CVE-2022-25568.yaml

## Other vulnerabilities in n/a

- [CVE-2025-60787](https://insights.sbomify.com/CVE-2025-60787/): motionEye vulnerable to RCE via unsanitized motion config parameter (high 7.2)
- [CVE-2021-44255](https://insights.sbomify.com/CVE-2021-44255/): Unrestricted Upload of File with Dangerous Type in motionEye (high 7.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-25568 and fix it if it is affected.

What it is: CVE-2022-25568 is a high-severity vulnerability in n/a, published on 24 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-25568 exists.

Affected packages and fixed versions:
- motioneye (PyPI): affected all versions; fixed in 0.43.1b1
- motioneye (PyPI): affected all versions; fixed in 0.43.1b1
- motioneye (PyPI): affected all versions; fixed in 0.43.1b1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-25568/ (Markdown: https://insights.sbomify.com/CVE-2022-25568/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-25568
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-25568
- OSV: https://osv.dev/vulnerability/CVE-2022-25568

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-25568/
Summaries are generated and may contain mistakes; the official description above is the record.
