# CVE-2022-25598: Apache DolphinScheduler user registration is vulnerable to ReDoS attacks


- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 30 Mar 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-qg5x-66hp-cw5p, PYSEC-2022-176

## What is CVE-2022-25598?

CVE-2022-25598 is a high-severity vulnerability in Apache DolphinScheduler, published on 30 Mar 2022. 

### Official description

Apache DolphinScheduler user registration is vulnerable to Regular express Denial of Service (ReDoS) attacks, Apache DolphinScheduler users should upgrade to version 2.0.5 or higher.

Weakness: CWE-1333 (Inefficient Regular Expression Complexity)

## Which versions are affected by CVE-2022-25598?

5 open source packages ship an affected version, including apache-dolphinscheduler and org.apache.dolphinscheduler:dolphinscheduler. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-dolphinscheduler` | PyPI | All versions | 2.0.5 |
| `apache-dolphinscheduler` | PyPI | All versions | 2.0.5 |
| `apache-dolphinscheduler` | PyPI | All versions | 2.0.5 |
| `org.apache.dolphinscheduler:dolphinscheduler` | Maven | All versions | 2.0.5 |
| `org.apache.dolphinscheduler:dolphinscheduler` | Maven | All versions | 2.0.5 |

Products: Apache Dolphinscheduler.

## How do I fix CVE-2022-25598?

Upgrade apache-dolphinscheduler to 2.0.5 or later.

## Is CVE-2022-25598 being exploited?

There is no known exploitation of CVE-2022-25598 in the wild and no public exploit code.

## Other vulnerabilities in Apache DolphinScheduler

- [CVE-2024-43166](https://insights.sbomify.com/CVE-2024-43166/): Apache DolphinScheduler Incorrect Default Permissions Vulnerability (critical 9.8)
- [CVE-2024-43202](https://insights.sbomify.com/CVE-2024-43202/): Apache DolphinScheduler: Remote Code Execution Vulnerability (critical 9.8)
- [CVE-2023-49109](https://insights.sbomify.com/CVE-2023-49109/): Remote Code Execution in Apache Dolphinscheduler (critical 9.8)
- [CVE-2022-45875](https://insights.sbomify.com/CVE-2022-45875/): Apache DolphinScheduler: Remote command execution Vulnerability in script alert plugin (critical 9.8)
- [CVE-2022-45462](https://insights.sbomify.com/CVE-2022-45462/): Apache DolphinScheduler prior to 2.0.5 have command execution vulnerability (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-25598 and fix it if it is affected.

What it is: CVE-2022-25598 is a high-severity vulnerability in Apache DolphinScheduler, published on 30 Mar 2022. 
Exploitation: There is no known exploitation of CVE-2022-25598 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache-dolphinscheduler (PyPI): affected all versions; fixed in 2.0.5
- apache-dolphinscheduler (PyPI): affected all versions; fixed in 2.0.5
- apache-dolphinscheduler (PyPI): affected all versions; fixed in 2.0.5
- org.apache.dolphinscheduler:dolphinscheduler (Maven): affected all versions; fixed in 2.0.5
- org.apache.dolphinscheduler:dolphinscheduler (Maven): affected all versions; fixed in 2.0.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-25598/ (Markdown: https://insights.sbomify.com/CVE-2022-25598/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-25598
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-25598
- OSV: https://osv.dev/vulnerability/CVE-2022-25598

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-25598/
Summaries are generated and may contain mistakes; the official description above is the record.
