# CVE-2022-25602: File upload in Responsive Menu (WordPress plugin)

> An attacker can exploit a nonce token leak to upload arbitrary files, delete themes, or change plugin settings in the Responsive Menu WordPress plugin.

- **Severity:** High 8.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 18 Mar 2022
- **Updated:** 28 Apr 2026
- **Also known as:** GHSA-g6mw-6vmq-3w32

## What is CVE-2022-25602?

CVE-2022-25602 is a high-severity vulnerability in ExpressTech Responsive Menu (WordPress plugin), published on 18 Mar 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Nonce token leak vulnerability leading to arbitrary file upload, theme deletion, plugin settings change discovered in Responsive Menu WordPress plugin (versions <= 4.1.7).

Weakness: CWE-434 (Unrestricted Upload of File with Dangerous Type), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2022-25602?

It affects 1 product.


Products: Expresstech Responsive Menu.

## How do I fix CVE-2022-25602?

No fix has been published for CVE-2022-25602 yet. Limit exposure of the affected software until one is available.

## Is CVE-2022-25602 being exploited?

There is no known exploitation of CVE-2022-25602 in the wild and no public exploit code.

## Other vulnerabilities in ExpressTech Responsive Menu (WordPress plugin)

- [CVE-2021-24160](https://insights.sbomify.com/CVE-2021-24160/): Responsive Menu 4.0.0 - 4.0.3 - Authenticated Arbitrary File Upload (high 8.8)
- [CVE-2021-24161](https://insights.sbomify.com/CVE-2021-24161/): Responsive Menu < 4.0.4 - CSRF to Arbitrary File Upload (high 8.8)
- [CVE-2021-24162](https://insights.sbomify.com/CVE-2021-24162/): Responsive Menu < 4.0.4 - CSRF to Settings Update (high 8.8)
- [CVE-2017-18513](https://insights.sbomify.com/CVE-2017-18513/): Cross-site request forgery in n/a (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-25602 and fix it if it is affected.

What it is: CVE-2022-25602 is a high-severity vulnerability in ExpressTech Responsive Menu (WordPress plugin), published on 18 Mar 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-25602 in the wild and no public exploit code.

Affected product: ExpressTech Responsive Menu (WordPress plugin). No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-25602/ (Markdown: https://insights.sbomify.com/CVE-2022-25602/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-25602
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-25602
- OSV: https://osv.dev/vulnerability/CVE-2022-25602

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-25602/
Summaries are generated and may contain mistakes; the official description above is the record.
