{"answers":{"affected":"5 open source packages ship an affected version, including mongoose. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-2564 exists.","fix":"Upgrade mongoose to a fixed version for your release line: 5.13.15 or 6.4.6.","what":"CVE-2022-2564 is a high-severity vulnerability in automattic/mongoose, published on 28 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-2564 and fix it if it is affected.\n\nWhat it is: CVE-2022-2564 is a high-severity vulnerability in automattic/mongoose, published on 28 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-2564 exists.\n\nAffected packages and fixed versions:\n- mongoose (Bitnami): affected all versions; fixed in 5.13.15, 6.4.6\n- mongoose (npm): affected all versions; fixed in 5.13.15\n- mongoose (npm): affected all versions; fixed in 5.13.15\n- mongoose (npm): affected from 6.0.0; fixed in 6.4.6\n- mongoose (npm): affected from 6.0.0; fixed in 6.4.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-2564/ (Markdown: https://insights.sbomify.com/CVE-2022-2564/index.md)","id":"CVE-2022-2564","markdown":"https://insights.sbomify.com/CVE-2022-2564/index.md","name":"CVE-2022-2564","record":{"aliases":["BIT-mongoose-2022-2564","CVE-2022-24304","GHSA-f825-f98c-gj3g"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js ODM library","requires_auth":"none","summary":"Prototype pollution in Mongoose allows attackers to manipulate object prototypes, potentially leading to code execution or privilege escalation.","user_interaction":"not_required","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"@huntrdev","cpe":[{"product":"mongoose","vendor":"mongoosejs"}],"cvss":{"score":7,"severity":"high","source":"cna","vector":"CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:H","version":"3.0"},"cwes":[{"id":"CWE-1321","name":"Improperly Controlled Modification of Object Prototype Attributes"}],"description":"Prototype Pollution in GitHub repository automattic/mongoose prior to 6.4.6.","ecosystems":["Bitnami","npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Prototype Pollution in automattic/mongoose","id":"CVE-2022-2564","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"other","year":"2022"},"n_packages":5,"n_references":4,"next":{"headline":"Best Payments Plugin for WP \u003c 4.2.1 - Unauthenticated Stored Cross-Site Scripting","id":"CVE-2022-2565"},"packages":[{"ecosystem":"Bitnami","fixed":["5.13.15","6.4.6"],"introduced":["0","6.0.0"],"last_affected":[],"package":"mongoose","purl":"pkg:bitnami/mongoose","source":"BIT-mongoose-2022-2564"},{"ecosystem":"npm","fixed":["5.13.15"],"introduced":["0"],"last_affected":[],"package":"mongoose","purl":null,"source":"GHSA-f825-f98c-gj3g"},{"ecosystem":"npm","fixed":["5.13.15"],"introduced":["0"],"last_affected":[],"package":"mongoose","purl":"pkg:npm/mongoose","source":"GHSA-f825-f98c-gj3g"},{"ecosystem":"npm","fixed":["6.4.6"],"introduced":["6.0.0"],"last_affected":[],"package":"mongoose","purl":null,"source":"GHSA-f825-f98c-gj3g"},{"ecosystem":"npm","fixed":["6.4.6"],"introduced":["6.0.0"],"last_affected":[],"package":"mongoose","purl":"pkg:npm/mongoose","source":"GHSA-f825-f98c-gj3g"}],"prev":{"headline":"Tutor LMS \u003c 2.0.10 - Admin+ Stored Cross-Site Scripting","id":"CVE-2022-2563"},"products":["automattic/mongoose"],"published":"2022-07-28","related":[{"cvss_score":10,"headline":"Prototype Pollution in automattic/mongoose","id":"CVE-2023-3696","kev_date_added":null,"published":"2023-07-17"},{"cvss_score":9.1,"headline":"Mongoose search injection vulnerability","id":"CVE-2024-53900","kev_date_added":null,"published":"2024-12-02"},{"cvss_score":9.1,"headline":"Improper Input Validation in Automattic Mongoose","id":"CVE-2019-17426","kev_date_added":null,"published":"2019-10-10"},{"cvss_score":9,"headline":"Mongoose search injection vulnerability","id":"CVE-2025-23061","kev_date_added":null,"published":"2025-01-15"},{"cvss_score":7.5,"headline":"Mongoose: Improper Sanitization of $nor in sanitizeFilter May Allow NoSQL Injection","id":"CVE-2026-42334","kev_date_added":null,"published":"2026-05-14"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-11-20","vendors":["automattic"]},"summary":"Prototype pollution in Mongoose allows attackers to manipulate object prototypes, potentially leading to code execution or privilege escalation.","url":"https://insights.sbomify.com/CVE-2022-2564/"}