# CVE-2022-25645: Prototype Pollution

> Attackers can achieve prototype pollution in the dset library via crafted objects, potentially leading to code execution or privilege escalation.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:L/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 May 2022
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-23wx-cgxq-vpwx, ROOT-APP-NPM-CVE-2022-25645

## What is CVE-2022-25645?

CVE-2022-25645 is a medium-severity vulnerability in dset, published on 1 May 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

All versions of package dset are vulnerable to Prototype Pollution via 'dset/merge' mode, as the dset function checks for prototype pollution by validating if the top-level path contains __proto__, constructor or protorype. By crafting a malicious object, it is possible to bypass this check and achieve prototype pollution.

Weakness: CWE-1321 (Improperly Controlled Modification of Object Prototype Attributes)

## Which versions are affected by CVE-2022-25645?

4 open source packages ship an affected version, including org.webjars.npm:dset and dset. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.webjars.npm:dset` | Maven | All versions | 3.1.2 |
| `org.webjars.npm:dset` | Maven | All versions | 3.1.2 |
| `dset` | npm | All versions | 3.1.2 |
| `dset` | npm | All versions | 3.1.2 |

Products: Dset Project Dset.

## How do I fix CVE-2022-25645?

Upgrade org.webjars.npm:dset to 3.1.2 or later.

## Is CVE-2022-25645 being exploited?

There is no known exploitation of CVE-2022-25645 in the wild and no public exploit code.

## Other vulnerabilities in dset

- [CVE-2020-28277](https://insights.sbomify.com/CVE-2020-28277/): dset vulnerable to prototype pollution (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-25645 and fix it if it is affected.

What it is: CVE-2022-25645 is a medium-severity vulnerability in dset, published on 1 May 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-25645 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.webjars.npm:dset (Maven): affected all versions; fixed in 3.1.2
- org.webjars.npm:dset (Maven): affected all versions; fixed in 3.1.2
- dset (npm): affected all versions; fixed in 3.1.2
- dset (npm): affected all versions; fixed in 3.1.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-25645/ (Markdown: https://insights.sbomify.com/CVE-2022-25645/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-25645
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-25645
- OSV: https://osv.dev/vulnerability/CVE-2022-25645

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-25645/
Summaries are generated and may contain mistakes; the official description above is the record.
