# CVE-2022-25647: Deserialization of Untrusted Data

> Attackers can cause denial of service in applications using Gson by exploiting unsafe deserialization in internal classes.

- **Severity:** High 7.7 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 May 2022
- **Updated:** 27 May 2026
- **Also known as:** CLEANSTART-2026-CW52413, CLEANSTART-2026-HP73429, CLSA-2026-1772669614, CLSA-2026-1787036800, CLSA-2026-1793128689, DEBIAN-CVE-2022-25647, DLA-3001-1, DLA-3100-1, DSA-5227-1, GHSA-4jrv-ppp4-jm57, MGASA-2022-0340, OESA-2022-1663, RHLW-2026-91a888529dd87fbc, SNYK-JAVA-COMGOOGLECODEGSON-1730327, SUSE-SU-2022:2044-1, SUSE-SU-2022:3706-1, UBUNTU-CVE-2022-25647, USN-6692-1, openSUSE-SU-2024:12040-1

## What is CVE-2022-25647?

CVE-2022-25647 is a high-severity unsafe deserialization vulnerability in Debian Debian Linux, published on 1 May 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The package com.google.code.gson:gson before 2.8.9 are vulnerable to Deserialization of Untrusted Data via the writeReplace() method in internal classes, which may lead to DoS attacks.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2022-25647?

2 open source packages ship an affected version, including com.google.code.gson:gson. It affects 6 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.google.code.gson:gson` | Maven | All versions | 2.8.9 |
| `com.google.code.gson:gson` | Maven | All versions | 2.8.9 |
| `google-gson` | SUSE:Enterprise Storage 7 | All versions | 2.8.9-150200.3.6.3 |
| `google-gson` | SUSE:Linux Enterprise High Performance Computing 15 SP2-ESPOS | All versions | 2.8.9-150200.3.6.3 |
| `google-gson` | SUSE:Linux Enterprise High Performance Computing 15 SP2-LTSS | All versions | 2.8.9-150200.3.6.3 |
| `google-gson` | SUSE:Linux Enterprise Module for Development Tools 15 SP3 | All versions | 2.8.9-150200.3.6.3 |
| `google-gson` | SUSE:Linux Enterprise Module for Development Tools 15 SP4 | All versions | 2.8.9-150200.3.6.3 |
| `google-gson` | SUSE:Linux Enterprise Server 15 SP2-BCL | All versions | 2.8.9-150200.3.6.3 |
| `google-gson` | SUSE:Linux Enterprise Server 15 SP2-LTSS | All versions | 2.8.9-150200.3.6.3 |
| `google-gson` | SUSE:Linux Enterprise Server for SAP Applications 15 SP2 | All versions | 2.8.9-150200.3.6.3 |
| `google-gson` | SUSE:Manager Proxy 4.1 | All versions | 2.8.9-150200.3.6.3 |
| `google-gson` | SUSE:Manager Retail Branch Server 4.1 | All versions | 2.8.9-150200.3.6.3 |
| `google-gson` | SUSE:Manager Server 4.1 | All versions | 2.8.9-150200.3.6.3 |
| `google-gson` | SUSE:Manager Server Module 4.1 | All versions | 2.8.9-150200.3.7.1 |
| `google-gson` | SUSE:Manager Server Module 4.2 | All versions | 2.8.9-150200.3.6.3 |
| `google-gson` | SUSE:Manager Server Module 4.3 | All versions | 2.8.9-150200.3.6.3 |
| `google-gson` | openSUSE:Leap 15.3 | All versions | 2.8.9-150200.3.6.3 |
| `google-gson` | openSUSE:Leap 15.4 | All versions | 2.8.9-150200.3.6.3 |

Products: Debian Debian Linux, Google Gson, Netapp Active Iq Unified Manager, Oracle Financial Services Crime and Compliance Management Studio, Oracle Graalvm, Oracle Retail Order Broker.

## How do I fix CVE-2022-25647?

Upgrade com.google.code.gson:gson to 2.8.9 or later.

## Is CVE-2022-25647 being exploited?

There is no known exploitation of CVE-2022-25647 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-25647 and fix it if it is affected.

What it is: CVE-2022-25647 is a high-severity unsafe deserialization vulnerability in Debian Debian Linux, published on 1 May 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-25647 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.google.code.gson:gson (Maven): affected all versions; fixed in 2.8.9
- com.google.code.gson:gson (Maven): affected all versions; fixed in 2.8.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-25647/ (Markdown: https://insights.sbomify.com/CVE-2022-25647/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-25647
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-25647
- OSV: https://osv.dev/vulnerability/CVE-2022-25647

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-25647/
Summaries are generated and may contain mistakes; the official description above is the record.
