{"answers":{"affected":"3 open source packages ship an affected version, including git. It affects 4 products.","exploited":"There is no known exploitation of CVE-2022-25648 in the wild and no public exploit code.","fix":"Upgrade git to 1.11.0 or later.","what":"CVE-2022-25648 is a high-severity command injection vulnerability in Debian Debian Linux, published on 19 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-25648 and fix it if it is affected.\n\nWhat it is: CVE-2022-25648 is a high-severity command injection vulnerability in Debian Debian Linux, published on 19 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-25648 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- git (Bitnami): affected all versions; fixed in 1.11.0\n- git (RubyGems): affected all versions; fixed in 1.11.0\n- git (RubyGems): affected all versions; fixed in 1.11.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-25648/ (Markdown: https://insights.sbomify.com/CVE-2022-25648/index.md)","id":"CVE-2022-25648","markdown":"https://insights.sbomify.com/CVE-2022-25648/index.md","name":"CVE-2022-25648","record":{"aliases":["BIT-git-2022-25648","DEBIAN-CVE-2022-25648","GHSA-69p6-wvmq-27gg","MGASA-2022-0248","SNYK-RUBY-GIT-2421270","UBUNTU-CVE-2022-25648"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby git library","requires_auth":"none","summary":"Attackers can execute arbitrary commands via argument injection in the Ruby git library's fetch function, requiring an upgrade to mitigate.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"snyk","cpe":[{"product":"debian_linux","vendor":"debian"},{"product":"extra_packages_for_enterprise_linux","vendor":"fedoraproject"},{"product":"fedora","vendor":"fedoraproject"},{"product":"git","vendor":"git"}],"cvss":{"score":8.1,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H/E:P","version":"3.1"},"cwes":[{"id":"CWE-88","name":"Improper Neutralization of Argument Delimiters in a Command"}],"description":"The package git before 1.11.0 are vulnerable to Command Injection via git argument injection. When calling the fetch(remote = 'origin', opts = {}) function, the remote parameter is passed to the git fetch subcommand in a way that additional flags can be set. The additional flags can be used to perform a command injection.","ecosystems":["Bitnami","RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Command Injection","id":"CVE-2022-25648","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"debian:debian_linux","products":["debian:debian_linux","fedoraproject:extra_packages_for_enterprise_linux","fedoraproject:fedora"],"type":"command_injection","year":"2022"},"n_packages":3,"n_references":7,"next":{"headline":"WordPress Affiliate For WooCommerce premium plugin \u003c= 4.7.0 - Multiple Improper Access Control vulnerabilities","id":"CVE-2022-25649"},"packages":[{"ecosystem":"Bitnami","fixed":["1.11.0"],"introduced":["0"],"last_affected":[],"package":"git","purl":"pkg:bitnami/git","source":"BIT-git-2022-25648"},{"ecosystem":"RubyGems","fixed":["1.11.0"],"introduced":["0"],"last_affected":[],"package":"git","purl":null,"source":"GHSA-69p6-wvmq-27gg"},{"ecosystem":"RubyGems","fixed":["1.11.0"],"introduced":["0"],"last_affected":[],"package":"git","purl":"pkg:gem/git","source":"GHSA-69p6-wvmq-27gg"}],"prev":{"headline":"Deserialization of Untrusted Data","id":"CVE-2022-25647"},"products":["git"],"published":"2022-04-19","related":[{"cvss_score":10,"headline":"ProFTPD Improper Access Control","id":"CVE-2015-3306","kev_date_added":"2026-10-08","published":"2015-05-18"},{"cvss_score":9.9,"headline":"RoundCube Webmail Deserialization of Untrusted Data","id":"CVE-2025-49113","kev_date_added":"2026-02-20","published":"2025-06-02"},{"cvss_score":9.8,"headline":"GNU InetUtils Argument Injection","id":"CVE-2026-24061","kev_date_added":"2026-01-26","published":"2026-01-21"},{"cvss_score":9.8,"headline":"Linux Kernel Improper Check for Unusual or Exceptional Conditions","id":"CVE-2025-39682","kev_date_added":"2026-09-18","published":"2025-09-05"},{"cvss_score":9.8,"headline":"Mozilla Firefox Use-After-Free","id":"CVE-2024-9680","kev_date_added":"2024-10-15","published":"2024-10-09"},{"cvss_score":9.8,"headline":"RARLAB UnRAR Directory Traversal","id":"CVE-2022-30333","kev_date_added":"2022-08-09","published":"2022-05-09"},{"cvss_score":9.8,"headline":"Roundcube Webmail SQL Injection","id":"CVE-2021-44026","kev_date_added":"2023-06-22","published":"2021-11-19"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["n/a"]},"summary":"Attackers can execute arbitrary commands via argument injection in the Ruby git library's fetch function, requiring an upgrade to mitigate.","url":"https://insights.sbomify.com/CVE-2022-25648/"}