# CVE-2022-25648: Command Injection

> Attackers can execute arbitrary commands via argument injection in the Ruby git library's fetch function, requiring an upgrade to mitigate.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Apr 2022
- **Updated:** 16 Sep 2024
- **Also known as:** BIT-git-2022-25648, DEBIAN-CVE-2022-25648, GHSA-69p6-wvmq-27gg, MGASA-2022-0248, SNYK-RUBY-GIT-2421270, UBUNTU-CVE-2022-25648

## What is CVE-2022-25648?

CVE-2022-25648 is a high-severity command injection vulnerability in Debian Debian Linux, published on 19 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The package git before 1.11.0 are vulnerable to Command Injection via git argument injection. When calling the fetch(remote = 'origin', opts = {}) function, the remote parameter is passed to the git fetch subcommand in a way that additional flags can be set. The additional flags can be used to perform a command injection.

Weakness: CWE-88 (Improper Neutralization of Argument Delimiters in a Command)

## Which versions are affected by CVE-2022-25648?

3 open source packages ship an affected version, including git. It affects 4 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `git` | Bitnami | All versions | 1.11.0 |
| `git` | RubyGems | All versions | 1.11.0 |
| `git` | RubyGems | All versions | 1.11.0 |

Products: Debian Debian Linux, Fedoraproject Extra Packages for Enterprise Linux, Fedoraproject Fedora, Git Git.

## How do I fix CVE-2022-25648?

Upgrade git to 1.11.0 or later.

## Is CVE-2022-25648 being exploited?

There is no known exploitation of CVE-2022-25648 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-25648 and fix it if it is affected.

What it is: CVE-2022-25648 is a high-severity command injection vulnerability in Debian Debian Linux, published on 19 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-25648 in the wild and no public exploit code.

Affected packages and fixed versions:
- git (Bitnami): affected all versions; fixed in 1.11.0
- git (RubyGems): affected all versions; fixed in 1.11.0
- git (RubyGems): affected all versions; fixed in 1.11.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-25648/ (Markdown: https://insights.sbomify.com/CVE-2022-25648/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-25648
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-25648
- OSV: https://osv.dev/vulnerability/CVE-2022-25648

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-25648/
Summaries are generated and may contain mistakes; the official description above is the record.
