# CVE-2022-25757: Apache APISIX: the body_schema check in request-validation plugin can be bypassed

> Attackers can bypass request validation in Apache APISIX by exploiting JSON duplicate key handling differences between the gateway and upstream services.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Mar 2022
- **Updated:** 3 Aug 2024
- **Also known as:** BIT-apisix-2022-25757, GHSA-9xhv-qfpf-p2xx

## What is CVE-2022-25757?

CVE-2022-25757 is a critical vulnerability in Apache APISIX, published on 28 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In Apache APISIX before 2.13.0, when decoding JSON with duplicate keys, lua-cjson will choose the last occurred value as the result. By passing a JSON with a duplicate key, the attacker can bypass the body_schema validation in the request-validation plugin. For example, `{"string_payload":"bad","string_payload":"good"}` can be used to hide the "bad" input. Systems satisfy three conditions below are affected by this attack: 1. use body_schema validation in the request-validation plugin 2. upstream application uses a special JSON library that chooses the first occurred value, like jsoniter or gojay 3. upstream application does not validate the input anymore. The fix in APISIX is to re-encode the validated JSON input back into the request body at the side of APISIX. Improper Input Validation vulnerability in __COMPONENT__ of Apache APISIX allows an attacker to __IMPACT__. This issue affects Apache APISIX Apache APISIX version 2.12.1 and prior versions.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2022-25757?

1 open source package ship an affected version, including apisix. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apisix` | Bitnami | All versions | 2.13.0 |

Products: Apache Apisix.

## How do I fix CVE-2022-25757?

Upgrade apisix to 2.13.0 or later.

## Is CVE-2022-25757 being exploited?

There is no known exploitation of CVE-2022-25757 in the wild and no public exploit code.

## Other vulnerabilities in Apache APISIX

- [CVE-2022-24112](https://insights.sbomify.com/CVE-2022-24112/): Apache APISIX Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2026-31908](https://insights.sbomify.com/CVE-2026-31908/): Apache APISIX: forward auth plugin allows header injection (critical 9.1)
- [CVE-2026-75005](https://insights.sbomify.com/CVE-2026-75005/): Apache APISIX: Unauthenticated CPU-exhaustion DoS (high 8.7)
- [CVE-2025-27446](https://insights.sbomify.com/CVE-2025-27446/): Privilege escalation in Apache APISIX Java Plugin Runner (high 7.8)
- [CVE-2026-31923](https://insights.sbomify.com/CVE-2026-31923/): Apache APISIX: Openid-connect `tls_verify` field is disabled by default (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-25757 and fix it if it is affected.

What it is: CVE-2022-25757 is a critical vulnerability in Apache APISIX, published on 28 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-25757 in the wild and no public exploit code.

Affected packages and fixed versions:
- apisix (Bitnami): affected all versions; fixed in 2.13.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-25757/ (Markdown: https://insights.sbomify.com/CVE-2022-25757/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-25757
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-25757
- OSV: https://osv.dev/vulnerability/CVE-2022-25757

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-25757/
Summaries are generated and may contain mistakes; the official description above is the record.
