CVE-2022-25765 Command Injection

High 7.3 Published Updated

Attackers can execute arbitrary commands via unsanitized URLs in the pdfkit Ruby library, requiring an upgrade to mitigate.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2022-25765?

CVE-2022-25765 is a high-severity command injection vulnerability in Fedoraproject Fedora, published on 9 Sep 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

The package pdfkit from 0.0.0 are vulnerable to Command Injection where the URL is not properly sanitized.

Which versions are affected by CVE-2022-25765?

2 open source packages ship an affected version, including pdfkit. It affects 2 products.

PackageAffectedFixed in
pdfkit RubyGemsAll versions0.8.7.2
pdfkit RubyGemsAll versions0.8.7.2

Products include Fedoraproject Fedora, Pdfkit Project Pdfkit.

How do I fix CVE-2022-25765?

Upgrade pdfkit to 0.8.7.2 or later.

Upgrade, and pass arguments to programs as a list instead of through a shell. More about Command injection.

Is CVE-2022-25765 being exploited?

There is no known exploitation of CVE-2022-25765 in the wild and no public exploit code.

Public exploit code: 10 proofs of concept on GitHub.

All Fedoraproject Fedora vulnerabilities

Sources

Also known as GHSA-rhwx-hjx2-x4qr.

Is CVE-2022-25765 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free