{"answers":{"affected":"2 open source packages ship an affected version, including pdfkit. It affects 2 products.","exploited":"There is no known exploitation of CVE-2022-25765 in the wild and no public exploit code.","fix":"Upgrade pdfkit to 0.8.7.2 or later.","what":"CVE-2022-25765 is a high-severity command injection vulnerability in Fedoraproject Fedora, published on 9 Sep 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-25765 and fix it if it is affected.\n\nWhat it is: CVE-2022-25765 is a high-severity command injection vulnerability in Fedoraproject Fedora, published on 9 Sep 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-25765 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- pdfkit (RubyGems): affected all versions; fixed in 0.8.7.2\n- pdfkit (RubyGems): affected all versions; fixed in 0.8.7.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-25765/ (Markdown: https://insights.sbomify.com/CVE-2022-25765/index.md)","id":"CVE-2022-25765","markdown":"https://insights.sbomify.com/CVE-2022-25765/index.md","name":"CVE-2022-25765","record":{"aliases":["GHSA-rhwx-hjx2-x4qr"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby PDF library","requires_auth":"none","summary":"Attackers can execute arbitrary commands via unsanitized URLs in the pdfkit Ruby library, requiring an upgrade to mitigate.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"snyk","cpe":[{"product":"fedora","vendor":"fedoraproject"},{"product":"pdfkit","vendor":"pdfkit_project"}],"cvss":{"score":7.3,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L/E:P","version":"3.1"},"cwes":[],"description":"The package pdfkit from 0.0.0 are vulnerable to Command Injection where the URL is not properly sanitized.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":"2022-12-04","github_poc":10,"max_poc_stars":31,"metasploit":0,"nuclei":0,"refs":[{"date":"2023-02-10T00:50:35Z","kind":"github_poc","ref":"https://github.com/UNICORDev/exploit-CVE-2022-25765","stars":31,"title":"Exploit for CVE-2022–25765 (pdfkit) - Command Injection"},{"date":"2022-12-04T21:00:05Z","kind":"github_poc","ref":"https://github.com/PurpleWaveIO/CVE-2022-25765-pdfkit-Exploit-Reverse-Shell","stars":20,"title":"pdfkit \u003c0.8.6 command injection shell. The package pdfkit from 0.0.0 are vulnerable to Command Injection where the URL is not properly sanitized. (Tested on ver 0.8.6) - CVE-2022-25765"},{"date":"2022-12-20T14:59:41Z","kind":"github_poc","ref":"https://github.com/shamo0/PDFkit-CMD-Injection","stars":16,"title":"CVE-2022-25765 pdfkit \u003c0.8.6 command injection."},{"date":"2023-01-29T10:36:40Z","kind":"github_poc","ref":"https://github.com/nikn0laty/PDFkit-CMD-Injection-CVE-2022-25765","stars":10,"title":"Exploit for CVE-2022-25765 command injection in pdfkit \u003c 0.8.6"},{"date":"2022-12-11T14:02:49Z","kind":"github_poc","ref":"https://github.com/LordRNA/CVE-2022-25765","stars":3,"title":"PoC for Blind RCE for CVE-2022-25765 (Tested in HTB - Precious Machine)"},{"date":"2022-12-07T15:04:59Z","kind":"github_poc","ref":"https://github.com/Wai-Yan-Kyaw/PDFKitExploit","stars":0,"title":"A Shell exploit for CVE-2022-25765"},{"date":"2023-02-21T17:38:51Z","kind":"github_poc","ref":"https://github.com/lekosbelas/PDFkit-CMD-Injection","stars":0,"title":"CVE-2022-25765 pdfkit 0.8.6 command injection."},{"date":"2024-01-22T14:45:34Z","kind":"github_poc","ref":"https://github.com/lowercasenumbers/CVE-2022-25765","stars":0,"title":"Exploit for CVE-2022-25765"}],"tier":"poc_unverified"},"has_fix":true,"headline":"Command Injection","id":"CVE-2022-25765","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":"fedoraproject:fedora","products":["fedoraproject:fedora"],"type":"command_injection","year":"2022"},"n_packages":2,"n_references":7,"next":{"headline":"Remote Code Execution (RCE)","id":"CVE-2022-25766"},"packages":[{"ecosystem":"RubyGems","fixed":["0.8.7.2"],"introduced":["0"],"last_affected":[],"package":"pdfkit","purl":null,"source":"GHSA-rhwx-hjx2-x4qr"},{"ecosystem":"RubyGems","fixed":["0.8.7.2"],"introduced":["0"],"last_affected":[],"package":"pdfkit","purl":"pkg:gem/pdfkit","source":"GHSA-rhwx-hjx2-x4qr"}],"prev":{"headline":"Improper input validation on HTTP/2 headers","id":"CVE-2022-25763"},"products":["pdfkit"],"published":"2022-09-09","related":[{"cvss_score":9.8,"headline":"PHP-CGI OS Command Injection","id":"CVE-2024-4577","kev_date_added":"2024-06-12","published":"2024-06-09"},{"cvss_score":9.8,"headline":"Grafana Authentication Bypass","id":"CVE-2021-39226","kev_date_added":"2022-08-25","published":"2021-10-05"},{"cvss_score":9.8,"headline":"VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow","id":"CVE-2019-5544","kev_date_added":"2021-11-03","published":"2019-12-06"},{"cvss_score":9.6,"headline":"Google Chromium V8 Type Confusion","id":"CVE-2024-4947","kev_date_added":"2024-05-20","published":"2024-05-15"},{"cvss_score":9.6,"headline":"Google Chromium Visuals Use-After-Free","id":"CVE-2024-4671","kev_date_added":"2024-05-13","published":"2024-05-09"},{"cvss_score":9.6,"headline":"Google Chromium Mojo Insufficient Data Validation","id":"CVE-2022-3075","kev_date_added":"2022-09-08","published":"2022-09-26"},{"cvss_score":9.6,"headline":"Google Chromium Indexed DB API Use-After-Free","id":"CVE-2021-30633","kev_date_added":"2021-11-03","published":"2021-10-08"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["n/a"]},"summary":"Attackers can execute arbitrary commands via unsanitized URLs in the pdfkit Ruby library, requiring an upgrade to mitigate.","url":"https://insights.sbomify.com/CVE-2022-25765/"}