# CVE-2022-25765: Command Injection

> Attackers can execute arbitrary commands via unsanitized URLs in the pdfkit Ruby library, requiring an upgrade to mitigate.

- **Severity:** High 7.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Sep 2022
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-rhwx-hjx2-x4qr

## What is CVE-2022-25765?

CVE-2022-25765 is a high-severity command injection vulnerability in Fedoraproject Fedora, published on 9 Sep 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The package pdfkit from 0.0.0 are vulnerable to Command Injection where the URL is not properly sanitized.

## Which versions are affected by CVE-2022-25765?

2 open source packages ship an affected version, including pdfkit. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pdfkit` | RubyGems | All versions | 0.8.7.2 |
| `pdfkit` | RubyGems | All versions | 0.8.7.2 |

Products: Fedoraproject Fedora, Pdfkit Project Pdfkit.

## How do I fix CVE-2022-25765?

Upgrade pdfkit to 0.8.7.2 or later.

## Is CVE-2022-25765 being exploited?

There is no known exploitation of CVE-2022-25765 in the wild and no public exploit code.

Public exploit code:

- Exploit for CVE-2022–25765 (pdfkit) - Command Injection (github_poc): https://github.com/UNICORDev/exploit-CVE-2022-25765
- pdfkit <0.8.6 command injection shell. The package pdfkit from 0.0.0 are vulnerable to Command Injection where the URL is not properly sanitized. (Tested on ver 0.8.6) - CVE-2022-25765 (github_poc): https://github.com/PurpleWaveIO/CVE-2022-25765-pdfkit-Exploit-Reverse-Shell
- CVE-2022-25765 pdfkit <0.8.6 command injection. (github_poc): https://github.com/shamo0/PDFkit-CMD-Injection
- Exploit for CVE-2022-25765 command injection in pdfkit < 0.8.6 (github_poc): https://github.com/nikn0laty/PDFkit-CMD-Injection-CVE-2022-25765
- PoC for Blind RCE for CVE-2022-25765 (Tested in HTB - Precious Machine) (github_poc): https://github.com/LordRNA/CVE-2022-25765
- A Shell exploit for CVE-2022-25765 (github_poc): https://github.com/Wai-Yan-Kyaw/PDFKitExploit

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-25765 and fix it if it is affected.

What it is: CVE-2022-25765 is a high-severity command injection vulnerability in Fedoraproject Fedora, published on 9 Sep 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-25765 in the wild and no public exploit code.

Affected packages and fixed versions:
- pdfkit (RubyGems): affected all versions; fixed in 0.8.7.2
- pdfkit (RubyGems): affected all versions; fixed in 0.8.7.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-25765/ (Markdown: https://insights.sbomify.com/CVE-2022-25765/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-25765
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-25765
- OSV: https://osv.dev/vulnerability/CVE-2022-25765

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-25765/
Summaries are generated and may contain mistakes; the official description above is the record.
