{"answers":{"affected":"2 open source packages ship an affected version, including ungit. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-25766 in the wild and no public exploit code.","fix":"Upgrade ungit to 1.5.20 or later.","what":"CVE-2022-25766 is a high-severity command injection vulnerability in ungit, published on 21 Mar 2022. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-25766 and fix it if it is affected.\n\nWhat it is: CVE-2022-25766 is a high-severity command injection vulnerability in ungit, published on 21 Mar 2022. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-25766 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- ungit (npm): affected all versions; fixed in 1.5.20\n- ungit (npm): affected all versions; fixed in 1.5.20\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-25766/ (Markdown: https://insights.sbomify.com/CVE-2022-25766/index.md)","id":"CVE-2022-25766","markdown":"https://insights.sbomify.com/CVE-2022-25766/index.md","name":"CVE-2022-25766","record":{"aliases":["GHSA-hf8c-xr89-vfm5","SNYK-JS-UNGIT-2414099"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"ungit Git client","requires_auth":"low_privilege","summary":"Attackers can execute arbitrary commands via argument injection in the /api/fetch endpoint of ungit, requiring an upgrade to secure the tool.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"snyk","cpe":[{"product":"ungit","vendor":"ungit_project"}],"cvss":{"score":8.8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-88","name":"Improper Neutralization of Argument Delimiters in a Command"}],"description":"The package ungit before 1.5.20 are vulnerable to Remote Code Execution (RCE) via argument injection. The issue occurs when calling the /api/fetch endpoint. User controlled values (remote and ref) are passed to the git fetch command. By injecting some git options it was possible to get arbitrary command execution.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Remote Code Execution (RCE)","id":"CVE-2022-25766","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"command_injection","year":"2022"},"n_packages":2,"n_references":3,"next":{"headline":"Remote Code Execution","id":"CVE-2022-25767"},"packages":[{"ecosystem":"npm","fixed":["1.5.20"],"introduced":["0"],"last_affected":[],"package":"ungit","purl":null,"source":"GHSA-hf8c-xr89-vfm5"},{"ecosystem":"npm","fixed":["1.5.20"],"introduced":["0"],"last_affected":[],"package":"ungit","purl":"pkg:npm/ungit","source":"GHSA-hf8c-xr89-vfm5"}],"prev":{"headline":"Command Injection","id":"CVE-2022-25765"},"products":["ungit"],"published":"2022-03-21","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["n/a"]},"summary":"Attackers can execute arbitrary commands via argument injection in the /api/fetch endpoint of ungit, requiring an upgrade to secure the tool.","url":"https://insights.sbomify.com/CVE-2022-25766/"}