# CVE-2022-25766: Remote Code Execution (RCE)

> Attackers can execute arbitrary commands via argument injection in the /api/fetch endpoint of ungit, requiring an upgrade to secure the tool.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Mar 2022
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-hf8c-xr89-vfm5, SNYK-JS-UNGIT-2414099

## What is CVE-2022-25766?

CVE-2022-25766 is a high-severity command injection vulnerability in ungit, published on 21 Mar 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The package ungit before 1.5.20 are vulnerable to Remote Code Execution (RCE) via argument injection. The issue occurs when calling the /api/fetch endpoint. User controlled values (remote and ref) are passed to the git fetch command. By injecting some git options it was possible to get arbitrary command execution.

Weakness: CWE-88 (Improper Neutralization of Argument Delimiters in a Command)

## Which versions are affected by CVE-2022-25766?

2 open source packages ship an affected version, including ungit. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ungit` | npm | All versions | 1.5.20 |
| `ungit` | npm | All versions | 1.5.20 |

Products: Ungit Project Ungit.

## How do I fix CVE-2022-25766?

Upgrade ungit to 1.5.20 or later.

## Is CVE-2022-25766 being exploited?

There is no known exploitation of CVE-2022-25766 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-25766 and fix it if it is affected.

What it is: CVE-2022-25766 is a high-severity command injection vulnerability in ungit, published on 21 Mar 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-25766 in the wild and no public exploit code.

Affected packages and fixed versions:
- ungit (npm): affected all versions; fixed in 1.5.20
- ungit (npm): affected all versions; fixed in 1.5.20

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-25766/ (Markdown: https://insights.sbomify.com/CVE-2022-25766/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-25766
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-25766
- OSV: https://osv.dev/vulnerability/CVE-2022-25766

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-25766/
Summaries are generated and may contain mistakes; the official description above is the record.
