# CVE-2022-25834: Command injection in n/a

> Attackers can execute arbitrary commands via crafted filenames in Percona XtraBackup, requiring local access to the file system.

- **Severity:** High 7.8 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Jun 2023
- **Updated:** 7 Jan 2025
- **Also known as:** BIT-percona-xtrabackup-2022-25834, BIT-percona-xtrabackup-binary-2022-25834, GHSA-hhfm-2xhw-4542, UBUNTU-CVE-2022-25834, USN-6745-1

## What is CVE-2022-25834?

CVE-2022-25834 is a high-severity command injection vulnerability in n/a, published on 7 Jun 2023. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

In Percona XtraBackup (PXB) through 2.2.24 and 3.x through 8.0.27-19, a crafted filename on the local file system could trigger unexpected command shell execution of arbitrary commands.

Weakness: CWE-77 (Improper Neutralization of Special Elements used in a Command)

## Which versions are affected by CVE-2022-25834?

2 open source packages ship an affected version, including percona-xtrabackup and percona-xtrabackup-binary. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `percona-xtrabackup` | Bitnami | All versions | 2.2.24, 8.0.27-19 |
| `percona-xtrabackup-binary` | Bitnami | All versions | 2.2.24, 8.0.27-19 |

Products: Percona Xtrabackup.

## How do I fix CVE-2022-25834?

Upgrade percona-xtrabackup to a fixed version for your release line: 2.2.24 or 8.0.27-19.

## Is CVE-2022-25834 being exploited?

There is no known exploitation of CVE-2022-25834 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2022-26944](https://insights.sbomify.com/CVE-2022-26944/): Information disclosure in n/a (medium 6.5)
- [CVE-2020-10997](https://insights.sbomify.com/CVE-2020-10997/): Information disclosure in n/a (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-25834 and fix it if it is affected.

What it is: CVE-2022-25834 is a high-severity command injection vulnerability in n/a, published on 7 Jun 2023. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-25834 in the wild and no public exploit code.

Affected packages and fixed versions:
- percona-xtrabackup (Bitnami): affected all versions; fixed in 2.2.24, 8.0.27-19
- percona-xtrabackup-binary (Bitnami): affected all versions; fixed in 2.2.24, 8.0.27-19

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-25834/ (Markdown: https://insights.sbomify.com/CVE-2022-25834/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-25834
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-25834
- OSV: https://osv.dev/vulnerability/CVE-2022-25834

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-25834/
Summaries are generated and may contain mistakes; the official description above is the record.
