# CVE-2022-25839: Improper Input Validation

> An attacker can spoof hostnames in the url-js library by exploiting improper input validation during URL parsing, potentially bypassing security checks.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Mar 2022
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-rf54-44jr-q5vf, SNYK-JS-URLJS-2414030

## What is CVE-2022-25839?

CVE-2022-25839 is a medium-severity vulnerability in url-js, published on 11 Mar 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The package url-js before 2.1.0 are vulnerable to Improper Input Validation due to improper parsing, which makes it is possible for the hostname to be spoofed. http://\\\\\\\\localhost and http://localhost are the same URL. However, the hostname is not parsed as localhost, and the backslash is reflected as it is.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2022-25839?

2 open source packages ship an affected version, including url-js. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `url-js` | npm | All versions | 2.1.0 |
| `url-js` | npm | All versions | 2.1.0 |

Products: Url-Js Project Url-Js.

## How do I fix CVE-2022-25839?

Upgrade url-js to 2.1.0 or later.

## Is CVE-2022-25839 being exploited?

There is no known exploitation of CVE-2022-25839 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-25839 and fix it if it is affected.

What it is: CVE-2022-25839 is a medium-severity vulnerability in url-js, published on 11 Mar 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-25839 in the wild and no public exploit code.

Affected packages and fixed versions:
- url-js (npm): affected all versions; fixed in 2.1.0
- url-js (npm): affected all versions; fixed in 2.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-25839/ (Markdown: https://insights.sbomify.com/CVE-2022-25839/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-25839
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-25839
- OSV: https://osv.dev/vulnerability/CVE-2022-25839

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-25839/
Summaries are generated and may contain mistakes; the official description above is the record.
